NewCelica.org Forum banner
1 - 13 of 13 Posts

·
Electromagnetic Wave :-h
Joined
·
15,835 Posts
Look for a leaky intake manifold gasket (common issue on early GT) or other vacuum leak. You were on the right track with the MAF. Most hesitation as described is MAF reading related. Any unmetered airflow will cause issues.
 

·
Electromagnetic Wave :-h
Joined
·
15,835 Posts
Depending on the actual DOM, you've likely got an oil burner. P0420 is a common issue w/them fouling the cat. P0171 is a common CEL for MAF/vacuum issues (unmetered air entering). P03XX would misfires (which can be the result of P0171).

While it won't actually solve the cat problem, you can mask it by adding a spark plug defouler to the post-cat sensor.
 

·
Electromagnetic Wave :-h
Joined
·
15,835 Posts
Can you look at your fuel trims or the freeze frame data from the P03XX cels?

This could be a cam or crank sensor issue or ignition related.
 

·
Electromagnetic Wave :-h
Joined
·
15,835 Posts

·
Electromagnetic Wave :-h
Joined
·
15,835 Posts
Lol... Far as I know, we don't have a bank 2 for fuel trims.

Short term fuel trims should usually show in low numbers, as they are just corrections from/to the long term trim. Long term trims should usually be less than 10. Anything > 20 should trip a CEL. Long terms in the 10-20 range may indicate a potential issue that is being corrected by the ECU.
 

·
Electromagnetic Wave :-h
Joined
·
15,835 Posts
I usually recommend the direct-fits. If you're going to splice in another sensor, I recommend making the splice in the cab where it will be dry.
 

·
Electromagnetic Wave :-h
Joined
·
15,835 Posts

·
Electromagnetic Wave :-h
Joined
·
15,835 Posts
What did you use to clean the MAFs? MAF cleaner or something else?

Is the butterfly operating correctly in the OEM airbox? Air filter condition?

What brand fuel are using?
 

·
Electromagnetic Wave :-h
Joined
·
15,835 Posts
I have noticed several threads talking about the butterfly in the OEM airbox, even seen some pics but mine doesn't seem to have a butterfly or even a place where one looks to be missing.
Take a pic please.
 

·
Electromagnetic Wave :-h
Joined
·
15,835 Posts
Thanks. Wanted to make sure the vac line was sealed off. You might want to just cap it at the manifold.
 

·
Electromagnetic Wave :-h
Joined
·
15,835 Posts
An attempt at making a P0420 go away.....
I got to wondering, could this be a stuck vtec solenoid?
Lol... That's Honda. But, you do have a VVT solenoid.
 

·
Electromagnetic Wave :-h
Joined
·
15,835 Posts
Well.... You replaced the upstream O2... the complimentary sensor is the MAF. MAF measures air in, O2 oxygen out. Cold start & WOT are Open Loop. Everything else is Closed Loop & based on sensor feedback. Really want to see Freeze Frame data on CELs. Best I can see so far is @ -11.7 LTFT, it appears to be running rich. The attempt at masking the P0420 with a capacitor bypass says that the cat has been fouled for a while, likely running rich (MAF, vacuum leaks, upstream O2) and burning oil (pistons & rings). All fairly typical of early 1ZZs.
 

·
Electromagnetic Wave :-h
Joined
·
15,835 Posts
It takes about a tank of fuel for trims to readjust.
 
1 - 13 of 13 Posts
Top