NewCelica.org Forum banner

1 - 20 of 67 Posts

·
Super Moderator
Joined
·
12,227 Posts
Discussion Starter #1
I wanted this to be its own thread, I make too many references to it


1. the heater hose that goes into the side of the head should come from a GT-S, the GT hose is shorter than i would like. the other heater hose with the big dip in it is just fine.

2. the GT passenger motor mount works with the GT-S bracket that bolts to the block. so that is the only 2ZZ part that you need, ill post a picture when i get done. of what it looks like.

3. while the 1ZZ harness seems to work, using a 2ZZ harness will make the swap so much cleaner. things like the injectors run is a little different. If you wanted to go crazy, then you could cut open the harness and reshape the hard cover around the wires.

4. you definitely need the 2ZZ down-pipe that connects to the header. the 1ZZ is too small and the bolt holes don't line up.





Here you can see the crank position sensor and the knock sensor run behind the oil dipstick tube. Don't use the clips on the dipstick to hold the plugs, they are not long enough.



Here you can see the injector harness. Everything fits and lines up but it will be a little tight



This is the GT motor mount bolted up to the 2ZZ engine mount on the passenger side. you will need the black engine mount when you do this swap. The body mount from the GT can still be used here.



Here you see the side of the head and lift actuator. on a GT-S the ECU grounds are bolted to the lift actuator. because the harness isn't quite long enough there is a good spot on the valve cover to put them. is right under the fuel rail line. You can also see the heater hose going into the side of the head. The one in the picture is from a GT-S since i had extra parts. the GT hose is not long enough.

You can also see the Lift OCV and the oil pressure sensor for lift. These are the two plugs you need to order. the part number for them are
90980-11162, 90980-11363 for the plugs and the pigtails are 82998-12440. You need 3 pigtails. The part number for the pigtails that go into the ECU plugs are 82998-12740 and you need 3 of these too. When they come in ill post pics and how to install them



This is the coil part of the harness. Again you can see that it does work but the holes to mount it to the valve cover do not fit. Its not too ugly, but if you open the harness up you can make it look cleaner.



This is the GT SRI. it also works with a long enough coupler to the 2ZZ throttle body.




1. the plugs needed for the lift actuator OVC and oil pressure sensor are, 11162 and 11363. tell those numbers to a parts guy and he should be able to get them. As soon as i get them ill post the actual part numbers and where to plug them into the ECU plugs.











2. the hose to the brake booster is much different between the GT and GT-S. you need to go to autozone or wherever and get about 2 feet of 5/16 hose and run a new line from the booster to the throttle body. Ill take a pic of this too when i get the plugs done.

3. Since i dont have the Lift OCV plugged in its throwing a CEL for 1690 and 1692. That doesnt stop you from driving the car. just keep the RPMs below 6000 and you will be fine.

4. Im using the GT alternator too. no promelms at all

5. You do need the throttle cable from the cruise control to the throttle body from a GT-S also

ok i discovered something new. The car was running a little crappy, at full throttle the engine was doing nothing. and it bogged really bad. well after some digging and experimenting, and thanks to Boosted2.0 also, I discovered that the GT and GT-S TPS (throttle position sensor) are wired backwards. so at idle the ECU saw 90% throttle. so here is what you have to do

remove the TPS plug.






This is looking into the plug




you need something like this to pry out the white pin lock. its not supposed to come all the way out but it makes the job much easier, just pull it out.








What you need to do is swap the red and brown wires. after pulling out the white lock use the pointy tool to lift the tab holding in the wire pin.






This is the GT configuration, you need to swap the red and brown wires.
 

·
Super Moderator
Joined
·
12,227 Posts
Discussion Starter #2
oh that reminds me, yes you can use the GT throttle cable if you delete the cruise. I had a GT-S cable from the cruise to the TB, so i used that.

you can use the GT cluster, but you will be in the red zone after 7000 RPMs which is fine for a 2ZZ
 

·
Registered
Joined
·
26 Posts
Need help finishing 2zz swap

Me and my son just finished the swap with the great help of this site, made the job that much easier... We bought a JDM engine complete with 6 speed wiring harness and the 89666-20060 ECU. Although the car runs well at this point, I have a couple of issues that I appreciate some need help with:

1) The speedometer is not working at all. I noticed that the original 5 speed transmission had a sensor on the differential that the new 6 speed does not... Do I have to transfer this sensor or do I have to set up an ABS sensor on the wheel for the speedo to work?

2) I cannot read the ECU with my OBD2 reader (Innova 3100) that used to work well with the 1zz ECU, any thoughts? Do japaneese ECU not comply with OBD2? The CEL is on...

3) The idle is running at 1700 rpm at this point but the downpipe has not been replaced yet, I am hoping this will drop down once the downpipe is fixed.

Thank you in advance for your help
 

·
Registered
Joined
·
26 Posts
Thank you for the response. Swapped the speed sensor today, we now have a speedometer. CEL light did not come back on after reset... Checked for vacuum leaks but did not find any. We need to get the downpipe fixed permanently, maybe this is causing the high idle?
 

·
Vendor
Joined
·
15,564 Posts
Thank you for the response. Swapped the speed sensor today, we now have a speedometer. CEL light did not come back on after reset... Checked for vacuum leaks but did not find any. We need to get the downpipe fixed permanently, maybe this is causing the high idle?
check your fuel trims. If they are very low then it may be a leak at the IAC seal or at your throttle plate. I've been startign to see that a fair bit lately.
 

·
Registered
Joined
·
26 Posts
I did not swap the wires on the TPS sensor as I got the wiring harness with the 2zz motor and thought they would be in the right place. Does this TPS swap apply to 2zz harnesses also?

Will check the IAC seal, everything else seems to check out fine.
 

·
Registered
Joined
·
372 Posts
question i did this swap 500 miles ago i had 2zz from a 00 automatic, bought a 2zz harness from redceli, a knock sensor from a 00 gts(im thinkling maybe its not) and a c60 tranny from someone else....everything runs great except for the fact that i cant rev pass 7k wtf????? and like celicadad i cant read the ecu from the DLC, and everything is american
 

·
Super Moderator
Joined
·
12,227 Posts
Discussion Starter #13
Does this TPS swap apply to 2zz harnesses also?
no if you ahve a 2ZZ harness then you are fine.

question i did this swap 500 miles ago i had 2zz from a 00 automatic, bought a 2zz harness from redceli, a knock sensor from a 00 gts(im thinkling maybe its not) and a c60 tranny from someone else....everything runs great except for the fact that i cant rev pass 7k wtf????? and like celicadad i cant read the ecu from the DLC, and everything is american

if the code reader is not connecting then its either a JDM ECU or something in the wiring is wrong. as for not revving past 7K, thats either the lift bolts are broken or it could be a wrong knock sensor. post a pic of it and ill tell you if its right

this is the right knock sensor
 

·
Registered
Joined
·
26 Posts
Any ideas where to source the midpipe/flange?

I have visited many muffler shops today without any success to get a new flange welded on my midpipe to complete the 2zz conversion. Most shops have refered me to the scrap yards, but celicas are rare....

Walker exhaust does not seem to seel an aftermarket midpipe/cat for a GTS only GT. Magnaflow sells a direct fit piece but they do not distinguish between GT or GTS???

I found this flange from Megan, http://www.andysautosport.com/honda/2011_9999_cr-z/performance/exhaust/exhaust_hardware/megan_racing/mega00247328.html

Anyone know if this will work or alternatively where I can buy the necessary parts. I have posted an add in the wanted to buy section.

Thank you
 

·
Super Moderator
Joined
·
12,227 Posts
Discussion Starter #15
if its the right size then it will work. the problem is the 2ZZ flange is bigger than the 1ZZ. jump on car-part.com and call junkyards. just ask them to cut off the down pipe at the CAT and send you that section. it will be about 2 feet long with the flange.

they cant sell you the CAT but can perfectly cut it off.
 

·
Registered
Joined
·
26 Posts
2zz Swap complete

Just finished the 2zz swap. Resolved the flange issue by buying a complete midpipe with cat from a junkyard. Had an issue with the Idle Air Control Valve, was able to get a replacement from the guy who sold us the JDM engine, although it was initially seized, a bit of WD-40 did the trick to loosen it up. We still cannot read the ECU with the OBD2 reader because of the Japaneese ECU, but we will look at replacing this later on with a North American version.

We encountered a small issue with the reverse lights not coming on, oddly enough, when we resolved the speedometer issue, we took out the reverse light switch wire which was in the speedometer position on the huge connector that goes to the fuse block, both are blue wires with a red tracer...

Your site made this swap much easier than I could have ever believed, thank you all for posting great information as well as answers to my questions.
 

·
Vendor
Joined
·
15,564 Posts
Moving this to the engine swaps thread
 

·
Registered
Joined
·
82 Posts
Anyone use GT shifter cables and have problems? Everything was fine for a while then I lost reverse, checked it out and the cable is too long, think it was the rubber boot that was holding it together until the boot broke and i lost reverse. Any fixes to this or do i need a GTS cable. The other one is fine.
 
1 - 20 of 67 Posts
Top