NewCelica.org Forum banner

21 - 40 of 67 Posts

·
Registered
Joined
·
82 Posts
Mine was fine for almost a year. Its hard to explain but the rod at the end of the cable comes out too far out of the sleeve only when trying to get to reverse, the cable just buckles.
 

·
Premium Member
Joined
·
9,037 Posts
The cables are the same, but the shifter itself is different on the GT versus the GT-S. Usually a GT shifter works fine on a GT-S, however there were a couple of times where I was having trouble getting into reverse when I did auto to manual swaps and used a GT shifter base. I ended up having to trim a little bit of plastic which was preventing me from pushing the shifter far enough to the left to get it into reverse gear.
 

·
Premium Member
Joined
·
9,037 Posts
Reading your post again, are you sure you have the cable installed correctly and clipped into place at all four points?
 

·
Registered
Joined
·
82 Posts
I will try to take some pictures tomorrow if its not raining, the clip was the first thing i checked as i have had that problem before where the retainer wasnt pushed in far enough and came out and i lost reverse then most of the other gears followed that, i replaced the retainer and fixed the problem, but now its just the reverse and i can see what is happening, i do have a obx short shifter instaled maybe i will try to swap out the stock one and see if that helps
 

·
Registered
Joined
·
7,714 Posts
I've used a GT base, TWM short shifter, GT cables, and a c60 trans for 4+ years now, and haven't had an issue.

Make sure the cable is clipped in at the base, and the trans. I had one of the clips come loose at the base, and it wouldn't shift right.
 

·
GTS Turbo
Joined
·
1,111 Posts
This thread is money! Good work as always!
 

·
Registered
Joined
·
7,714 Posts
So, no mention of the power steering pump, but I think that's my serpentine belt issue.

I have an engine from a 2003 vibe gt, and the power steering pump pulley is quite a bit bigger than the celica GT's. Is the gt-s and gt power steering pump pulley the same for the celica?

I'm using the GT a/c compressor, GT-S alternator, GT power steering pump....I bought a belt for the GT-S and it has a good amount of slack. I assume I can buy a smaller belt, but I'd like to go ahead and exchange parts if that's the problem.
 

·
Registered
Joined
·
7,714 Posts
Actually..I looked in the repair manual, and it showed a different pump for GT & GT-S, and they have different part numbers. I used the pump from the vibe gt, and everything is good now.
 

·
Registered
Joined
·
492 Posts
Quick couple of questions regarding this swap:

-Are the midpipes the same diameter between the GT and GTS? is it only the flange that mates to the exhaust manifold that are different? Is there any difference between the two CATs?

Is the GTS throttle cable necessary? I have the GTS cruise cable, but am not entirely clear on the GT/GTS throttle cable situation.

Any further info would be greatly appreciated!
 

·
Premium Member
Joined
·
12,227 Posts
Discussion Starter #32
not sure about the diameter, its the angle of the midpipe thats off.

if you have the GTS cruise cable then you will be fine. the GT cable is shaped different at the throttle body.
 

·
Registered
Joined
·
492 Posts
Will I have to use the GTS cruise cable in lieu of the GT throttle cable? or is it just the cruise cables that are different? Also, if I have the midpipe flange from the GTS exhaust (I might, need to check), can I have that welded to the GT midpipe? I'm guessing as long as I replace the axle-back exhaust I shouldn't have any losses, right?
 

·
Premium Member
Joined
·
12,227 Posts
Discussion Starter #34
ok, ill explain it again. the cable from the pedal to the cruise controller is the same between cars.

the cable from the cruise controller to the throttle body are different. you need the GTS cable from the cruise controller to the throttle body.

yes you can have the GTS midpipe flange welded to the GT mid pipe. any competent muffler shop can handle this
 

·
Registered
Joined
·
82 Posts
The midpipe diameter is different from gt to gts by a 1/4 of an inch if memory serves me correct. Non cruise gt cable will work with a gts but you need to bend the cable or it will stick up and hit the hood.
 

·
Registered
Joined
·
7,714 Posts
The GT-S mid pipe is much bigger than the GT from the exhaust manifold down to the inlet of the CAT. I still used my GT CAT, but I used an exhaust expander so it would be easier to weld to the larger GT-S pipe, and flow better.
 

·
Registered
Joined
·
20 Posts
A quick question that someone will hopefully be able to answer. My dad and I recently did the 2ZZ swap into my 01 GT, and when we were trying to get the TPS wires switched, we couldn't get them pulled out of the plug, so we just cut the red and brown, and wired them back together. Will this cause any problems, or should it be fine?

I also had a problem where when I stepped on the throttle, the engine would bog down pretty hard (from about 1500 idle to less than 500) and then bounce back up (to about 2200-2500). I cleaned the MAF out (it was pretty dirty) and that seemed to mostly solve the problem, but it happened again the other day while I was driving. Any ideas? (my thought was the IAC might be sticking)
Any help is appreciated (sorry if I'm in the wrong spot, I'm new here)
 

·
Premium Member
Joined
·
12,227 Posts
Discussion Starter #40
A quick question that someone will hopefully be able to answer. My dad and I recently did the 2ZZ swap into my 01 GT, and when we were trying to get the TPS wires switched, we couldn't get them pulled out of the plug, so we just cut the red and brown, and wired them back together. Will this cause any problems, or should it be fine?
no it wont be a problem
I also had a problem where when I stepped on the throttle, the engine would bog down pretty hard (from about 1500 idle to less than 500) and then bounce back up (to about 2200-2500). I cleaned the MAF out (it was pretty dirty) and that seemed to mostly solve the problem, but it happened again the other day while I was driving. Any ideas? (my thought was the IAC might be sticking)
Any help is appreciated (sorry if I'm in the wrong spot, I'm new here)
just get a new MAF and clean the IAC.
 
21 - 40 of 67 Posts
Top