NewCelica.org Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
1,391 Posts
Discussion Starter · #1 ·
ok so last night i broke one neon while i was putting the counsol back on....today i went and got a new one and just spliced it into the old wire that the broke neon was on....then new neon worked and then i turned it off set it into place in the a/c area...then i turned it back on and i have no light??? i didnt break it and dont hear anyhting rattling when i shake the neon...i have checked my connection...i know power is coming cause the light is on box thing for the neon...what could my problem be????
 

·
Work Done, Sexy Time.
Joined
·
2,835 Posts
Like Blue Lucifer said, give it a minute when letting it start up. Mine is now taking awhile when it is really cold. Also check the easy things. Do you have it on always on or is it set accidentally to dance with the beat mode. Make sure that you don't have the wiring backwards as well.
 

·
Registered
Joined
·
1,391 Posts
Discussion Starter · #4 ·
what confuses me is i had it on all wired correctly and eveything and then i put it into place and now it wont turn on anymore...its on light not pulsar i checked.....really getting frustrated with this thing
 

·
Premium Member
Joined
·
9,606 Posts
Yeah, mine has done the same thing. Just stopped working...
The power light for the inverter is on, so I know its getting power... but I sure doesnt light up. I think I am going to take apart the power inverter to see if anything didnt shake loose in there....
 

·
Registered
Joined
·
1,391 Posts
Discussion Starter · #6 ·
its really annoying huh...its really getting to me now i just had to put things back together and leave it before i broke something i didnt want to cause i was getting mad at it :)
 

·
Registered
Joined
·
1,391 Posts
Discussion Starter · #8 ·
i have checked it to make sure everything is right bout 10 times now...just kinda gave up for awhile
 

·
Registered
Joined
·
1,308 Posts
Did u guys solder the wires or just splice it together w/ electrical tape? I soldered it and have had no problems. That could be what's wrong w/ your neons
 
1 - 10 of 10 Posts
Top