NewCelica.org Forum banner
1 - 14 of 14 Posts

·
Registered
Joined
·
528 Posts
Discussion Starter · #1 ·
fuk, do not use acetone to clean your speedo needles!!! i used it and it ate my fukin' needle...now i only have half of it left. brake fluid(dot3) works fine...by the way, would anyone have an extra speedo needle for me? damn, i need one asap...
 

·
Registered
Joined
·
2,595 Posts
yea.... acetone dissolves plastic. where did u get acetone? raid the high school lab? :D

sorry to hear that tho.... gluck finding a replacement.

just curious, were u trying to get the color off or... just wondering... how do u get it dirty if its inside that cover thing?
 

·
Registered
Joined
·
528 Posts
Discussion Starter · #11 ·
yeah i used the acetone to clean off the amber paint. man, this really sucks! even dot 3 made cracks in my tach needle, but it can only be seen at night. my luck sucks. i just had my cluster replaced under warranty last friday. how the h3ll am i gonna explain this one to the dealer! plus my damn calibration is off again! geeze!!! how do you guys not screw up your calibration when doing this job? especially with russ's gauge. man, i need a install write up on this thing! russ where are ya!!!
 

·
Registered
Joined
·
635 Posts
Yeah, Non-Acetone Nail Polish Remover works wonders! It only takes off other people's paint, not your own. I learned a quick lesson after hitting a nice cemet pole and got yellow paint all over the outside of my side-view mirror.
 

·
Registered
Joined
·
528 Posts
Discussion Starter · #14 · (Edited)
russ, is there a link to the led install? i saw the link to the gauge install and have that all figured out, but still can not get the led's in....i'm totally clueless on that part? i tried to link to an install page on your site but a message popped up saying that i did not have permission to enter...i need help with the led install. thanks!
 
1 - 14 of 14 Posts
Top