NewCelica.org Forum banner
1 - 19 of 19 Posts

· Banned
Joined
·
313 Posts
Discussion Starter · #1 ·
hey i was wondering if the aem pulley kit was bad for the 2zz-ge engine? i have i/e and ported header and i just ordered wheels and a kit so i need more hp to make up for the extra weight of the wheels, do the pulleys add any hp? and do they damage the engine?? i've blown 3 motors so im trying to play it safe thanks
Mert
 

· Zettai Unmei Mokushiroku
Joined
·
30,262 Posts
Originally posted by S|Lv3rBu||et
Actually, I heard from someone yesterday that if these aren't used in conjunction with an under drive crank pulley that you actually could stand to lose some power!
If you used the AEM alternator pulley with an underdrive crank pulley, you'd lose even more electrical power, since the alternator would be double underdriven. :eek:
 

· Registered
Joined
·
4,909 Posts
it's an underdrive pulley...there isn't much to be gained by it. maybe 1-2 whp tops..the stock alternator pulley is fine unless you want to spice up your mod list..and for $60 it's fairly cheap.

better gains are made by regular sized lightweight pulleys (or slightly underdriven, lightweight pulleys) instead of mainly concentrating on underdriving to give you some extra power.

IF you don't use your a/c much..you should be fine.
IF you have aftermarket sound (sub, amp, etc)..don't use it.
 

· Registered
Joined
·
1,974 Posts
i have had so many electrical problems (flying through optima batteries) ever since I got that damn pulley installed. If i wasn't so lazy I would take it out....
 

· Registered
Joined
·
1,974 Posts
i didn't at first either.......you just wait, haha

I think it slowly kills your alternator.

I just installed a brand new optima yellow top battery (my 3rd) and the same day when i was just idling it was at 12 volts, but it should be at 14.....
 

· Registered
Joined
·
1,419 Posts
Originally posted by JCelica132
think it slowly kills your alternator.
Who told you that? It spins the alternator SLOWER. If anything it would prolong it's life.
 

· Registered
Joined
·
1,974 Posts
LoL, no one told me that, that's why I said I think. It just seems like my alternator is getting weaker and weaker as time goes on.
 

· Registered
Joined
·
1,419 Posts
Originally posted by JCelica132
LoL, no one told me that, that's why I said I think. It just seems like my alternator is getting weaker and weaker as time goes on.
It could be your battery. If you garage your car a lot, drive a lot in stop and go traffic, etc. your probably not seeing enough load to get your battery recharged enough. Combining the underdriven pulley with any kind of audio system (amp/subs/etc) and that would also make things worse.
 

· Registered
Joined
·
1,118 Posts
i installed an aem pulley waay back when i had my GT. my power windows rolled down really slow. no dimming of the lights though. but i got some really good throttle response. my power windows came back to normal after i installed a grounding kit.
 

· Registered
Joined
·
1,974 Posts
143hawaii said:
It could be your battery. If you garage your car a lot, drive a lot in stop and go traffic, etc. your probably not seeing enough load to get your battery recharged enough. Combining the underdriven pulley with any kind of audio system (amp/subs/etc) and that would also make things worse.
I'm on my 3rd Optima yellow top Battery in a yr and a half. The same day I put my last one in it was already at 12 Volts when I was shifting, idling.
 
1 - 19 of 19 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top