NewCelica.org Forum banner
1 - 9 of 9 Posts

·
Registered
Joined
·
52 Posts
Discussion Starter · #1 ·
Little Rocket and I began deconstructing my Spyder today. While he was preparing to pull the motor, I was in the cabin pulling my gauges and a few other items. When I removed the AEM UEGO display gauge, it was abnormally tough. Upon further inspection, the case was melted and difficult to pull. LR and I were sitting around scratching our heads because the two Autometer gauages mounted next to it were fine and the wiring and plugs were fine. The gauge itself was working fine.

What we figured was that the gauge pod, which was mounted onto the center cubby on the dash, got too hot and just melted the gauge housing. I just googled "AEM UEGO melt" and the first hit was somebody on a DSM board who never hooked it up ("ricer style" in his words) and his melted.

Right now the plan is to call AEM and ask for a replacement gauge. Rather they give it to me or not, I plan to only setup to run it until the car is tuned. Then the whole mess can be pulled I may make a power supply patch for future use though. This way there's no doubt which three gauges to run in the A-Pillar pod and I don't have to come up with 6 to be able to run two pods when I only wanted 4 gauges.

The moral of the story is if you're going to by a UEGO, get the kind that doesn't require the gauge but will support an autometer AFR gauge. The UEGO is a bargain. The AEM gauge itself is crap.
 

·
Registered
Joined
·
1,241 Posts
hmm, no problems with mine, yet. i'll just have to keep my fingers crossed and hope nothing so dramatic happens to mine...
 

·
Vendor
Joined
·
15,564 Posts
Mine is fine, although it doesn't get much use unless I'm tuning for someone that doesn't have one (the one in my alltrac is the non gauge type - they didn't have them yet when I got mine)- did you have a good dedicated ground for it or did you piggyback off a different ground?

That will suck if its a design issue - its a really important peice of info for FI cars.
 

·
Registered
Joined
·
52 Posts
Discussion Starter · #8 ·
AEM told me to get bent. I can either send it back for an undetermined repair cost or buy a whole new unit. I plan on using it to log for tuning and then unhooking it.

Buy an Innovation gauge boys.
 

·
Vendor
Joined
·
15,564 Posts
I think autometer sells a wideband w/ gauge now too, no idea how good / bad it is though
 
1 - 9 of 9 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top