NewCelica.org Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
11 Posts
Discussion Starter · #1 ·
I have a 00 GT-S

When I rev my car up to about 6,000rpm a squealing noise starts. Its a high pitch annoying noise and it will continue until my car physically comes to a stop. There is no noise until it gets reved up a little. After the noise is apparent, I threw it into neutral to see if the noise would stop when the car was still moving and the noise continues. Its not until I come to a complete stop that the noise stops, and there is no squealing when the car is just idoling. There is no difference when the car has the A/C on, and I had the brakes are good.
I took it to toyota and they don't know what it is.

If you have any ideas on what it could be please tell me, thanks.
 

·
Bring on the 12's...
Joined
·
6,104 Posts
Sounds like the drive belt. I have had that problem for months!!! lol, i cant find the correct sized belt. I think the stock size needed is 6pk1940 for a stock set up.
 

·
Registered
Joined
·
419 Posts
check your shims on the edge of your brake pads, thehy could be rubbing against the rotors, i saw someone with this problem before, and he let it go on for so long that the shims actually seperated the hub from the rotor == brakes not workign because rotor spins independently
 

·
Registered
Joined
·
1,757 Posts
Belt tensioner. If your hearing a sqeaking pull on ur serp belt the one that goes on ur alternator if its lose then theres your problem.
 
1 - 4 of 4 Posts
Top