NewCelica.org Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
81 Posts
Discussion Starter #1
Hi guys, i'm having electrical problems on my celica just like these previous posts

http://www.newcelica.org/forums/showthread.php?t=226279
http://www.newcelica.org/forums/showthread.php?t=204836&highlight=electrical+problems

This problem began at least 6 months ago when i pulled out my crappy alarm system then my celica started trippin' 1-2months later.

I was able to turn my guages on (speedometer, gas, rpm) by using one of the 7.5 fuses rather than putting both 7.5 fuses, i've been driving like this for 6 motnhs already and it works just w/o powerlock, domelight, clock always at 1:00, etc.


vids to clarify what is said ^^
PART 1: http://s68.photobucket.com/albums/i...ew&current=photobucket-6134-1329678307628.mp4
PART 2: http://www.youtube.com/watch?v=n9_AXBIK2hw&feature=channel

Do i have the same problems as those older posts or am i experiencing something else? thank you very much!
 

·
Registered
Joined
·
224 Posts
Hey lad, i had similar problems after my ecu blew and i had to remove an aftermarket alarm/immobilizer before replacing it! Here's my thread http://www.newcelica.org/forums/showthread.php?t=337558
Basically it turned out to be the multifuses for me, they were not making a good connection with the socket, however, people with similar problems have found it to be the body ecu! Hope this helps! Also i still don't have wireless central locking so i may still have a body ecu issue!
 

·
Registered
Joined
·
81 Posts
Discussion Starter #3
Hey daz0095 thanks for the reply, yeah i saw your car last night while i was browsing about this problem! and alright, so i think i'll let my electrical mechanic test everything first before i go out to buy a new body ecu eh?

and what do you think about this (if they do confirm that it is the body ecu):
i go and get the body ecu + a new alarm system and have the electric shop both install em at the same time? prolly cost a lot but i think it's the best direction to go from here yeah?
 

·
Registered
Joined
·
224 Posts
Well basically i would try and figure out what caused the problem in the first place just in case it happens again, i have a feeling my problems were related to both incorrect installation and subsequently incorrect removal of the alarm but seen as you have already removed your alarm you should be fine. Did you jumpstart your car at any stage before this happened?
Also if you need to install a new alarm i would do it at the same time, sure, but make sure you get a guarantee and i would suggest, if it does turn out to be the bodyecu, trying to find a second hand one cause they're an absolute rip off new! Oh and yes get your mechanic to check everything before committing to buying a new ecu!
 

·
Registered
Joined
·
81 Posts
Discussion Starter #5
no i didnt have to jumpstart my car, oh i don't think i did a good job of removing the alarm as well. i just unplugged the alarm box and that's it... lol but yeah i'll have em installed at the same time if anything, but i have to wait til the end of this week until i can get it checked up. thank you, and i'll update as soon as i can ! :wiggle:
 

·
Registered
Joined
·
81 Posts
Discussion Starter #7
Hey it was the Body ECU as well!
Instead of replacing the whole thing $$$$ , my mechanic had a friend at toyota dealership that got the part from a crashed celica, and just replaced one part of the BCM. Got my car back yesterday and everything works perfectly :D
 

·
Registered
Joined
·
224 Posts
Really happy to hear you got this sorted man , what part of the ecu did you replace, was it the box under the fuse panel called the multiplex, if so i think that's the whole ecu or was it a specific part? Did you get a good deal on it? Im thinking or replacing mine too cause i just noticed yesterday that there are still some center console lights not working for me eventhough its not very noticeable and as i mentioned before my central locking is still dead!!
 

·
Registered
Joined
·
81 Posts
Discussion Starter #9
late reply again dang itt. i replaced a certain part inside the body multiplex, and yes! i feel the same as you, i think i'm still missing some functions still such as if i leave the lights on and turn of the car there should be a beeping noise... let me know how much you get the whole thing for! i called a toyota used parts dealer around my area, it goes for $100
 
1 - 9 of 9 Posts
Top