NewCelica.org Forum banner

1 - 20 of 28 Posts

·
Registered
Joined
·
6,340 Posts
Discussion Starter #1
I got a AEM cai and just changed my aem cone filter for an injen one that I have 1 week ago. I got a cel on monday code P0170, system too lean condition. The dealer told me that the problem is created by the air filter. Any help? the injen filters differ from aems?
 

·
Premium Member
Joined
·
4,756 Posts
injencelica with an aem cai??
 

·
Premium Member
Joined
·
4,756 Posts
did u try resetting the ecu? after i put on my k&n filter i reset the ecu and no cel, but then again i've never got a cel
 

·
Zettai Unmei Mokushiroku
Joined
·
28,865 Posts
Was the code P0170 or P0171? 170 is rich, 171 is lean. Was the Injen filter new or used? Was the AEM filter dirty and the Injen clean? If it's 171, it could possibly just be the freer airflow from a clean filter making you run lean (more air past the MAFS = more air unmetered).
 

·
Registered
Joined
·
6,340 Posts
Discussion Starter #7
I think it was P0171, the injen was used in good condition, the aem one was dirty and in bad condition... what I should do to solve the problem?

thanks for the help Blue!
 

·
Registered
Joined
·
6,340 Posts
Discussion Starter #9
is worth it to let on the cai on a gt? running lean will make the car slower? I'm thinking on just install the stock airbox back and forget about cai problems:)
 

·
Zettai Unmei Mokushiroku
Joined
·
28,865 Posts
Originally posted by InjenCelicaGT
running lean will make the car slower?
Running lean makes a bit more power up to a point, then it becomes dangerous to the engine. The ECU detects when it becomes dangerous and puts the car into safe mode, changing the AF ratio to richer than normal to prevent any damage. This actually loses power since it runs too rich.
Originally posted by InjenCelicaGT
I'm thinking on just install the stock airbox back and forget about cai problems:)
I guarantee if you do the mod in that link, it'll fix any intake related CELs or bogging. It has a 100% success rate. :)
 

·
Zettai Unmei Mokushiroku
Joined
·
28,865 Posts
If you still want to do the mod, you can always check the For Sale forum for a used airbox. They pop up every now and then. :)
 

·
Registered
Joined
·
6,340 Posts
Discussion Starter #14
I forgot to say that my car last one week with no cel after I put on the Injen filter, is that normal? I'm confused!
 

·
Zettai Unmei Mokushiroku
Joined
·
28,865 Posts
Yeah, that's just the ECU adjusting to the airflow and how you drive. It takes a while for it to find the optimal settings, and then decide that your car is running dangerously lean.
 

·
Registered
Joined
·
1,294 Posts
hey injen if you want you could always try replacing the cone filter with a new one and cleaning your tube. i bet you won't have any problems then since you didn't have them before the cone filter change.

anyways i have a new bottle of k&n filter cleaner and oil if you want to use it, also if you have the time we can clean the maf and throttle body to see what happens to that cel. my bogging completely stopped after the maf and throttle body cleaning;)

shoot me a pm if interested bro :)
 

·
Registered
Joined
·
6,340 Posts
Discussion Starter #18
thanks Ivan, pmed you!


I forgot to say too that I'm using now a injen filter from an injen gts cai. I think that they're the same but just in case, maybe the gt-s use a less restrictive one.
 
1 - 20 of 28 Posts
Top