NewCelica.org Forum banner
1 - 20 of 34 Posts

·
Registered
Joined
·
339 Posts
Discussion Starter · #1 ·
It's been 3 weeks now since I had to to my car to Toyota. I was out on the bottle for the first time this yr when all hell broke loose.

2000 GT, run 50 shot NX kit

First pass everything was fine.

Second pass, I softened up my shocks to see if I could get tires to stick better out of the hole. Didn't work, sucked actually, spinning really bad RPMs were going up really fast, I let off to jam it into second so I wouldn't hit the limiter, lot's of wheel hop. At about 6k in 2nd I hear a loud bang like a really loud backfire.

Immediately I fear the worst. So obviously car is dead, pull my plugs, no signs of damage at all.

Toyota has been through nearly everything. Compression is good, intake manifold is good, timing is good, vvti is good, all sensors indicate things are fine. Tried a new ECU. MAF sensor is good. It will run really rough w/o the MAF but when the maf is connected it will fire and die. Not sure what else I can tell you.

Before this I had my car on the road for a week, it was running fine and I am certain this wouldn't have happend if I hadn't been on the N20, but I'm stumped (and my knowledge is limited) the techs dunno what to do and I'm wondering what went wrong and how to avoid it in the future.

One question, can/does N20 degrade over time? When I filled the bottle I am certain it was the same cyl from last fall, which didn't really make me happy but I didn't have any reason to believe it would be a problem.

Anyone have any thoughts or ideas? Desperate really want to have my car back.
 

·
Registered
Joined
·
1,901 Posts
<gulp> i was just about to make a phone call to see if i could get my kit installed.......eh......
 

·
Registered
Joined
·
339 Posts
Discussion Starter · #4 ·
It's not the kit's fault, at least I don't think. I ran through a couple bottles last fall w/ no problems and my friend has had his GT-S juiced for some time. Tho my car had only been out of storage for a week, be nice to know what the problem is.
 

·
Registered
Joined
·
1,853 Posts
could it possibly be a transmission problem?

did you happen to suck something up into your intake tract?

perhaps you were running really rich, and now your cat is shot?

just tossing out ideas, its pretty odd that they couldnt find the problem, i'm assuming you took off the nitrous before you took it to the dealer correct?
 

·
Registered
Joined
·
339 Posts
Discussion Starter · #7 ·
50 shot jets, thought I mentioned that, the dealer here is good to me, prettyt ight w/ the service manager so they don't hassle me.

They removed the intake manifold to find that I had literally blown it apart, so hopefully that is the extent of it.
 

·
Registered
Joined
·
404 Posts
LOL that plastic POS LOL

sorry... I HATE the GT manifold..... what a joke....
Sorry about your problems good luck man...
 

·
Registered
Joined
·
339 Posts
Discussion Starter · #9 ·
Amen I hate that is plastic as well, too bad there isn't really any other options. Tho in this case I'm wondering if it being the weak link possibly saved me from more severe damage.
 

·
Registered
Joined
·
459 Posts
50 shot jets don't help me one bit.
my guess is you jetted it wrong, more fuel then your supposed to have, puddling, hence the back fire through in the manifold.

i need to know what nitrou jet and fuel jet is in the fogger nozzle.
 

·
Registered
Joined
·
339 Posts
Discussion Starter · #12 · (Edited)
I'd have to pullit apart to give you the numbers and since I don't have my car can't do this. It's jetted right to what the chart says w/ the NX kit, unless that chart is wrong it's not jetted wrong. Nothing has changed since I ran through the initial 2 bottles last yr.

The chart numbers are: 35N/20F

It's possible you are still correct tho, the only change this run was I set my Konis a lot softer hoping that I could get a bit better traction off the line and launched about about 3000-3200 instead of 4500 like I do NA. Didn't work for **** tho just hopped and spun like mad, first time ever I was scared I was gonna hit my limiter, in the midst of all that I think I waivered on the throttle a little bit, perhaps it hit WOT and disengaged and then immediately back on it again, all in 1st gear. Hard to say, happened so fast.

Looking on the NX page at their delay timer, and the progressive controller, obviously the delay timer is much cheaper anyone know how this might work?

I'm considering different ways to perhaps delay the torque in 1st gear, whether it means using a controller for a smaller spray(tho a conteroller cannot differentiate gears can it?) or would this delay timer perhaps let me launch NA and then hit it hi RPM or into 2nd???

Also anyone have any street tire recomendations for running the N20?
 

·
Registered
Joined
·
339 Posts
Discussion Starter · #14 ·
No it's definitely the tires, I have piece o' crap Paradas (pretty worn on top) and the spin is bad but it's the hop that makes it unbearable, even my stock tires spin like mad but don't hop like these bad boys.

Just undecided as to what to try next. Either the cheap route w/ the Kumho 712's I think it is, or maybe just maybe the SO3's but scared of burning them away in such a short time on the n2).
 

·
Registered
Joined
·
339 Posts
Discussion Starter · #18 ·
Another question, it was suggested by someone from our board that perhaps the temp variation of the intake manifold and the cold N20 could lead to cracks given the composite material used in the GT intake. Any thoughts on this?

My friend in service suggested that perhaps it was cracked before this as a partial explanation to my complaints of increased oil consumption last fall.
 

·
Registered
Joined
·
459 Posts
i ran a 36 nitrous and 22 fuel to be safe.
i was given this setup from a tech at N.O.S. who had nitrous on his gt celica.
im just passing the info along

it wasn't rich on my gts. gt might be a slight different
 
1 - 20 of 34 Posts
Top