NewCelica.org Forum banner

1 - 20 of 22 Posts

·
Registered
Joined
·
8,097 Posts
Discussion Starter #1
Anbody got a clue as to why? it has roughly 3.9-4 quarts of oil in it and a purolator oil filter and it is running like complete ass, like it has no power whatsoever. It is almost as if it has too much oil in it but I changed it myself nd it has exactly 3.9 quarts of oil which is exactly what it calls for. I just cannot figure out why it is running like ****. Any help will be greatly appreciated.

Justin
 

·
Registered
Joined
·
1,407 Posts
Check hoses and other connections. I am sure it isn't the oil unless you used something like 50w or something... Anyways it is prob something that got disconnected in the process. check and recheck..
 

·
Registered
Joined
·
8,097 Posts
Discussion Starter #3
No no 50W here lol. I used Mobil 1 5w-30 fully synthetic. Could it be possible thqat the filter is actually blocking the oil flow somewhat. I have read in the past that some oil filters actually hinder flow more than they help it.
 

·
Premium Member
Joined
·
13,784 Posts
Originally posted by DopeCelicaGT
No no 50W here lol. I used Mobil 1 5w-30 fully synthetic. Could it be possible thqat the filter is actually blocking the oil flow somewhat. I have read in the past that some oil filters actually hinder flow more than they help it.
yes.

ONLY USE TOYOTA FILTERS.
 

·
Registered
Joined
·
8,097 Posts
Discussion Starter #6
Oil level is fine but I do not have a oil pressure guage so there is now way I can check that. I am willing to bet it has something to do with the filter because as you know Mobil 1 Synthetic 5W-30 is some real thin crap. It was fine with the old filter but I changed filters, from STP to Purolator brand this time around and I am thinking it has something to do with that. I don't have a clue otherwise. I am also pretty sure I did not knowck any hoses or lines loose either. Anybody have any other ideas. I mean it acts like it has way too much oil in it but like I said earlier the oil level is perfect and i only used roughly 3.9 U.S. quarts. I am lost.
 

·
Registered
Joined
·
1,757 Posts
when was the last time you change ur oil did you change it at exactly 3,000?
 

·
Registered
Joined
·
1,445 Posts
never heard of purolator....how much did it cost?
my car always runs a little better after an oil change.
 

·
Registered
Joined
·
8,097 Posts
Discussion Starter #10
FrostsCelicaGTS said:
when was the last time you change ur oil did you change it at exactly 3,000?
Um, usually I try to change it every 3000 miles but since I am running synthetic I should be able to run at least 5000 before I technically need to change my oil but I do it every 3000 anyways, normall. I was a little late this time like 750 miles over but that is not really a big deal.

QTRMLR_1 said:
never heard of purolator....how much did it cost?
my car always runs a little better after an oil change.
Purolator has been around for a long time and too my knowledge were one of the first companies to develop oil and air filters. The filter itself cost me $3.98. As far as the car running better after an oil change, mine usually runs better as well, except for this time.

monkeywrench said:
Is the oil light on? That's the "gauge" that Toyota gave us.
Um, I don't really know whether to take your comment jokingly, as sarcasm or what LOL, but I assure you my oil light is not on. If it was I would shut the car off immediately and sure as hell would not be driving it. On top of that even if the oil light was on it would not make any difference. I do not even know why they waste the effort putting those things in cars because they are pointless. By the time the oil light came on, if it was really that low on oil, the damage would have been done anyways. I guess it would keep you from doing more damage but 9 times out of 10 if that light comes on then you can almost bet you have damaged your motor somehow.

Anyways keep the ideas of the problem flowing because it is still acting sluggish and I have yet to figure out the problem. Perhaps I should take it in to a mechanic or just keed driving the damn thing. I know it has oil in it, plenty, i just checked it when I got home. I let it sit for awhile and then went outside and checked it and it is actually reading a little lower than it should like maybe an 8th of an inch below the fill line. I haven't figured that out either because with roughly 4 quarts in it then it should be right on the fill line. I have also checked for leaks and cannot find one at all. I give up LOL. If anybody has any ideas please respond. Thanks for all the help guys.
 

·
Registered
Joined
·
1,634 Posts
DopeCelicaGT said:
Um, I don't really know whether to take your comment jokingly, as sarcasm or what LOL, but I assure you my oil light is not on.
I meant no disrespect, that light is just the only indication of oil pressure that we have to work with. It's a positive sign that the light is not on.

I'd say the odds of the oil being bad are poor. A defective oil filter is an extreme rarity but is possible. I'd change that ASAP.
 

·
Registered
Joined
·
8,097 Posts
Discussion Starter #12
monkeywrench said:
I meant no disrespect, that light is just the only indication of oil pressure that we have to work with. It's a positive sign that the light is not on.

I'd say the odds of the oil being bad are poor. A defective oil filter is an extreme rarity but is possible. I'd change that ASAP.
Oh yeah, trust me if the oil light was on I would not be this calm LOL, well its nothing to laugh about either way but you get what I mean. Yeah I think I am going to change the filter this weekend and see what happens. It is the only thing I can come up with thusfar.
 

·
Vendor
Joined
·
15,564 Posts
I have one other possibility. Check to make sure that the metal baffle you see on the inside of thevalve cover when you open the oil fill cap isn't bent down or hitting the cam reluctors for the VVTI or anything.

Also pull a few injectors just to be sure you don't have any oil puddling around the intake valves.
 

·
Registered
Joined
·
1,255 Posts
QTRMLR_1 said:
never heard of purolator....how much did it cost?
my car always runs a little better after an oil change.
Purolator is the company that makes most of the Japanese OEM filters. I wouldn't be surprised if the Toyota OEM filter is made by Purolator.
 

·
Registered
Joined
·
1,741 Posts
Originally posted by boostjunkie26
Purolator is the company that makes most of the Japanese OEM filters. I wouldn't be surprised if the Toyota OEM filter is made by Purolator.
i would think denso makes yota filters.
 

·
Vendor
Joined
·
15,564 Posts
jway83 said:
i would think denso makes yota filters.
They definitely make the Japanese ones - I forget who makes the US built ones though.
 

·
Registered
Joined
·
1,926 Posts
celica only take 4 quarts of oil?
 

·
Registered
Joined
·
1,926 Posts
LOL ive been filling my GT with 5 since day one. I guess i didnt hurt anything, still runs like a champ.
 

·
Registered
Joined
·
8,097 Posts
Discussion Starter #20
FL Honda Stompr said:
LOL ive been filling my GT with 5 since day one. I guess i didnt hurt anything, still runs like a champ.
Um, did you not ever check your dipstick when you were done? I mean 5 quarts of oil will put you a pretty good damn ways above the fill line. On top of that I would not do that anymore if I were you. Too much oil is just as bad or worse than having too little oil, depending on the circumstances and how little or how much over you are.
 
1 - 20 of 22 Posts
Top