NewCelica.org Forum banner
1 - 5 of 5 Posts

· Registered
Joined
·
6 Posts
Discussion Starter · #1 ·
2000 celica gts starts and dies, hissing sound

i recently changed the lift solenoids on my 2000 toyota celica gts to try and fix a check engine light, to change them i had to remove the intake manifold to get to the solenoids. i also had to remove the fuel injectors. Here’s what i did and the symptoms:

What i did/ any possible mistakes:
  • changed lift solenoids
  • removed intake manifold
  • spilled a lot of coolant upon disconnecting throttle body
  • removed fuel injectors
  • one of the fuel injectors popped off and spilled some fuel
  • snapped a lot of wiring clips

symptoms:
- starts for half a second and dies with a hissing sound

what i tried:
  • checked vacuum lines, all seems to be good
  • disconnected MAF sensor and tried starting the car, same result

misc:
  • spilled some coolant on a lot of stuff, maybe caused an electrical problem? (doubt it)
  • one of the electrical harnesses that connects to the throttle body was wet with coolant i think when i unplugged it(i don’t think it’s this because it was running fine before)

thank you in advance for the help, providing a list of things to check would be helpful, like all the vacuum lines to check and all the wiring harnesses to check
 

· Registered
Joined
·
583 Posts
Could be a dead MAF. Swap in a known good MAF from another Toyota or Lexus. They use the same DENSO MAF.

Check fuel pressure. Could be a dead fuel pump.

Tow it to a good Toyota dealer for diagnostic. Pay them $100 they can point you to the most likely causes.
 

· Registered
2004 Toyota Matrix XRS & XR Honda Lawnmower
Joined
·
17 Posts
The 'hissing' sound when the engine dies is likely the normal stabilizing of vacuum in the cylinders as the engine stops turning. I have multiple fully functioning 1zz-fe & 2zz-ge engines which all make a faint hiss when they are shut down because the crankshaft continues to turn for a half second after the ignition is cut and that generates compression in the cylinders, which 'hisses' as it escapes the cylinder into the intake or exhaust manifold of the stopped engine.

I don't think vacuum is your problem, it's more likely electrical. There are two eyelet ground straps which attach to the 'lift' solenoid with a couple 10mm nuts. Make sure these are clean and secure b/c I can tell you from experience that if they aren't attached the 2zz will do exactly what you described. Ask me how I know.

Best to check for CELs first it may indicate where there is a connection problem. Then go back over your work and use zip-ties to hold broken connectors together. If all of that checks out my guess is occam's razor: the solenoid you replaced your old one with is defective and needs replacement.
 
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top