NewCelica.org Forum banner

1 - 16 of 16 Posts

·
Registered
Joined
·
202 Posts
Discussion Starter #1
was driving down highway cruising at 80mph and the engine light came on out of nowhere. What could be causing this ? I have had CAI for about 2 months but I don't think this has anything to do with the problem.
 

·
Registered
Joined
·
12,350 Posts
Originally posted by alphasubzero949
Did you pull the code? If not, get it and then come back here and tell us.
Originally posted by hey11101
im not sure what you mean by " did you pull the code "
:chuckles:
 

·
Registered
Joined
·
202 Posts
Discussion Starter #8
alright went to autozone and they did CEL code thing and it said engine running lean. Which the guy told me probably because of clogged fuel injector. I think it could be fuel injector since their are some signs for example
I get a lot of pops in my exhaust maybe because the fuel isn't burnt due to bad fuel injector and I get the pop noise a lot while driving, my quarter mile performance went down, when I clean inside of my exhaust it gets black again pretty fast,takes couple of sec to start my car ( not enought fuel delivery during start up or just bad battery), went starting off in first gear from stop car feels like it wants to die, so I have to start at like 1500rpms most of time for good normal take off, the car does have 52K miles on it so it's possibility that it could be fuel injectors. The only thing that goes agianst all this is when car is idle it's rpms are perfect doesn't go up or down at all it's very leveled. I have injen intake but if that was causing the check engine light to come on it would have came on earlier not after 2 months or so after it's been installed. So what do you guys think ?
 

·
Registered
Joined
·
202 Posts
Discussion Starter #11
man I hope it's not my intake. I really don't want to spend like $80-$200 to get it diagnosed at toyota and then tell me " ohh it's your intake" because that be waste of money. I might try to put some fuel injector cleaner maybe that will help? and how can injen sell intakes that make your check engine light come on ? I mean injen is huge company it should do more research on the stuff they sell. tpr is a really small company and it puts out better intakes then injen and thats mest up because that just shows you how much injen sucks.
 

·
Registered
Joined
·
433 Posts
do this....open your hood...unplugg the battery..and save yourself 80 bucks...

i have an injen CAI and the light goes off only when i hit the 91fwy..so i stay away from that freeway
 

·
Registered
Joined
·
746 Posts
alphasubzero949 said:
Sounds like an issue with your MAFS.
Ya my MAFS always trips my CEL, but only when I'm on the freeway for a while, like Zero2sicksty said.

Oh well dood. Reset the CEL and just deal with it.
 

·
Zettai Unmei Mokushiroku
Joined
·
28,865 Posts
Originally posted by S.Menchavez
Oh well dood. Reset the CEL and just deal with it.
If the CEL is caused by the car running lean, you'll also have to deal with reduced power. The ECU puts the car into safe mode to protect the engine, which makes it run richer than normal to reduce temps (lean = hot).
 
1 - 16 of 16 Posts
Top