NewCelica.org Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
1,190 Posts
Discussion Starter · #1 ·
I just recently installed TRD lowering springs. Now whenever i go over a big bump in the road i hear a really loud *thunk*. Sounds like it is coming from the passenger/front corner. I am thinking possibly the stabilizer bar end link not tight enough? maybe?

Any other thoughts?
 

·
Registered
Joined
·
1,190 Posts
Discussion Starter · #3 ·
I just checked the nut on the top of the strut tonight before i decided to tear apart the whole thing again and wouldn't ya know it? Loose as a goose. Interesting. I specifically remember tightening these as much as i could when i installed them.
Thanks.
 

·
Registered
Joined
·
2,957 Posts
Lot of people have had this problem...I'm one of those...Do a search on this topic, and you will find your answer

I had this problem too long ago to help you out. My memory is gone on that subject
 

·
Registered
Joined
·
791 Posts
I too had this problem after having the TRD struts and sway bars installed. After tracking down the loose nut (front right strut) and tightening it up, the noise went away.

Search around for other discussions on this from a few months back. Someone noted to be careful not to tighten up the nut too much; there is apparently a speciific torque to which the nuts are to be tightened.
 
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top