NewCelica.org Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Hello to everyone

My problem is the following
All of a suddent i got all 3 indicators switched on.
Then the engine led switched off but the other two remain on although i unplugged the battery for more than 20 minutes and although i have driven the car for more than 400 miles.

In other non-celica fora i have noticed people claiming that this is due to maf sensor or due to co2 sensors before and after the catalytic converter on the exhaust pipe.

Has anybody something to add in order to help me?

If i have to replace any of those sensors can i used new but other than those of authorised dealer shop (they charge more than 300 dollars for each one of them while market ones are less than half of that price)

any advice will be welcomed
 

·
Spanning Tree Storm
Joined
·
1,264 Posts
Hi there!
I remember I had this once. They remained for some days time and then one day they turned off as suddenly as they turned on.
Now for O2 sensors , you can get aftermarket Denso sensors for cheaper than original sensors, i remember i had paid about $100 each.
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #4 ·
Well after visiting a local toyota dealer shop-garage the problem has been sorted out
The ecu part of the VSC and TRC required reprogramming due to the fact the codes had been locked. This cause propably by "bad" electrical circuit due to an eroded battery battery terminal wire....

Thankfully although they spend an hour on my problem they didnt charged me a peny
 
1 - 4 of 4 Posts
Top