NewCelica.org Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
72 Posts
Discussion Starter #1 (Edited)
SOLVED: Bad MAF!

Well I decided to sell my GTS this fall to make way for a bmw 3-series. I'm sick and tired of having to readjust my seat everytime i have passengers on.

My Celica has been a dream since I bought it in 2003 (It's a 2000 6-spd), but ever since I made the decision to sell her, the problems are just stocking up.

- Problem 1: (Engine) I wanted to make it as stock as possible and reinstalled the stock airbox. Now I have a P0171 and the car idles at about 1K. Sure sounds like a vacuum leak, but I can't find it. The car hesitates several times between 2,500-5000 RPMS, but hits lift like it always has.

- Problem 2: (Electrical) Next thing on the "don't you dare sell me" agenda was the rear washer controls. Everytime I want to wash the rear window, the front wipers turns on like I am spraying them as well.

- Problem 3: (Electrical) Latest event is that I all of a sudden have built-in automatic rain sensors. As I was driving to work this morning the wipers turned on by themselves and it didn't matter what I did, they would go on max speed with only sporadic pauses.

There are some other minor problems, but I should be able to fix those myself. Anyone know how to fix the three mentioned? I just want to get it all fixed so I can't get rid of her. I'm sure I will have to update this thread as new problems arrive...:bang:

Tip to everyone who is thinking about selling your Celica, don't mention it while you are driving her!
 

·
Registered
Joined
·
72 Posts
Discussion Starter #4
Smaay: I'll check the hoses again. I found this picture a while ago on this forum of all the vacuum hoses in the engine bay, but I am having a hard time finding it again.

I've cleaned the MAF twice since the first time I got the P0171 code with no luck. Could it be something wrong with the internals; valves perhaps? The car is burning more oil now than it used to.

Bonesaw: Number 3 is a short. When I left work yesterday, everything was back to normal. It had been sitting inside the parking garage drying off the wet snow, so I will have to locate this problem.

As to problem number 2, there is no change. Ever since the first day this problem occured, it has been persistent.

Thank you for quick replies :)
 

·
Registered
Joined
·
72 Posts
Discussion Starter #5
Noticed tonight while driving (the road was dry and the windshield wipers were going crazy again) that the wipers stopped just as i let my foot off the brake and backed up. I've read that several celica owners experience that their wipers starts as they accelerate. Maybe this is something similar? Could there just be a loose connection? Not too experienced with the electrical system... Any help would be great!
 

·
Registered
Joined
·
72 Posts
Discussion Starter #6
Have anyone experienced this or is there anyone who knows a little about the electrical set-up in the celica?

The windshield wipers are making me crazy! Do any of the wires run through the wheel well? I have lost the plastics on both sides, so I am thinking the problem could be there.

The wipers reacts when i pull the level all the way down, but that's the only control I have over them.

Any help would be great!
 
1 - 6 of 6 Posts
Top