NewCelica.org Forum banner
1 - 14 of 14 Posts

·
Registered
Joined
·
63 Posts
Discussion Starter · #1 ·
alrite, it's been about 4 months of the same problem, i've looked into it over 15 times and still no solution.

everytime i hit a dip or a bump, my front suspension will make a "bang" sound. like metal hitting metal. i had TRD springs and Koni shocks. i haven't touched anything else. y would it make this sound?

recently, i installed skunk2 coilovers and a new set of koni shocks, still the same problem. today i went under my car and used an impact wrench to tighten every single bolt i could see that has anything to do with the suspension, still have the same problem.

any type of advice, i'd like to hear, thanks guys. or if u kno any shops that specialize in suspension, please lemme kno.
 

·
Registered
Joined
·
63 Posts
Discussion Starter · #7 ·
Guy in Poway said:
maybe yout botteming out and its just your chassis hitting the road?
man that would be horrible.....my car was only lowered 1" w/ TRD springs, other people w/ 2" sportline drops weren't hitting their chassis so i doubt it's that. and plus, i was under my car for several hours today, i especially looked for signs of scratching, but found nothing....
 

·
Registered
Joined
·
1,639 Posts
i really dont know where the problem is in your suspension but you might also want to check how the springs are set on their perches. sometimes when you jack up the car, the spring could spin and not re-seat properly when it comes back down. this causes banging sounds.
 

·
Registered
Joined
·
63 Posts
Discussion Starter · #13 ·
yea i had that problem with my rear suspension, so i made sure to tighten the front sway bar endlinks....that doesn't seem to help....
 

·
Registered
Joined
·
1,443 Posts
is the sound coming from one corner of the car? or just the front or just the back? or just everwhere?.. are the springs seated right in the top part that holds the springs down? because ivie got a sound similar to that bang your talking about... when i looked.. it looked like the top nut was tightened all the way but was still moving up and down. i dunno what my friend did.. but he fixed it. i'll ask. but i doubt thats the same thing happening to you because you'd be able to notice it moving up and down. damnit i can't really describe it. but anyways.. this happened to someone else on the boards who was from pomona.. but i dunno his name on here.. although i know his AIM sn. let me know if you get it fixed.
 
1 - 14 of 14 Posts
Top