NewCelica.org Forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
12 Posts
Discussion Starter · #1 ·
Hello,

Here are the fuses that show no power when both battery terminals are connected.

When the positive and negative terminals are both connected to the battery some fuses don’t show any amps on the multimeter. The fuses are not blown.

If I remove the negative terminal from the battery and check those same fuses, the multimeter shows that they have amps going through them.

Then when I connect the negative terminal to the battery again the amps don’t show.


I looked around the car and I didn’t find any exposed wires. Here is a picture of something idk what it is.

55067


Any help is appreciated. Thank you
 

·
Registered
Joined
·
519 Posts
Some fuses wont have power untill what ever switch is activated. Is there somthing that isnt working or...?

2000 GTS Turbo
 

·
Registered
Joined
·
12 Posts
Discussion Starter · #3 ·
Some fuses wont have power untill what ever switch is activated. Is there somthing that isnt working or...?

2000 GTS Turbo
Hello, it’s a 2001 GT. It’s been having some issues where the cabin light turns on and the passaanger door locks then unlocks.
 

·
Registered
Joined
·
519 Posts
Sounds like a fault door switch imo, 2way is prolly the best when it comes to electrical issues hopefully they chime in on this 1.

But it makes sense in that regard. If a door switch thinks its still open then it wont let u lock the door and same with the lights. They wont shut off if the door.

2000 GTS Turbo
 

·
Registered
Joined
·
12 Posts
Discussion Starter · #5 ·
Sounds like a fault door switch imo, 2way is prolly the best when it comes to electrical issues hopefully they chime in on this 1.

But it makes sense in that regard. If a door switch thinks its still open then it wont let u lock the door and same with the lights. They wont shut off if the door.

2000 GTS Turbo
My concern is that it might be messing with the engine. Because when I’m driving on fifth gear it starting making this tick tick tick tick.i don’t have any trouble codes with the OB2 scanner. The car runs great even w the tapping sound.
Here is a video of the engine sound .
 

·
Klaatu barada nikto
Joined
·
1,925 Posts
Ever find out what that loose connector is for in your pic?
 
1 - 7 of 7 Posts
Top