NewCelica.org Forum banner
1 - 20 of 30 Posts

·
Registered
Joined
·
117 Posts
Discussion Starter · #1 ·
Did research in forum n didnt find an answer to this hopefully i get some help here. Celica takes around 3 key turns to start only when hot weather. After first cold/hot weather start the car would start right up i shut it off, car also feels slower n bogs. No issuesii at night time when its not so hot outside. Thinking it is the fuel pump starting to go out but also think it can be a kind of temperature sensor in the intake side of engine. Might be fuel pressure regulator but i dont think it can be affected by temperature so idk:marky:
 

·
Registered
Joined
·
8,329 Posts
We do use a returnless fuel system, if you're parked over black top that's radiating upward at like 150F, I could see the potential for vapor lock. If you cycle the key on/off several times to prime the fuel system first then start, does it start easier?

How long do you have to crank before it starts? Is it cranking? What do you mean by '3 key turns'?
 

·
Electromagnetic Wave :-h
Joined
·
15,689 Posts
Make sure that the Blue electrical connector is not plugged into the EVAP Purge VSV by mistake.

Do you get any CEL codes?

Running an after market intake?

Checked the IAT?
 

·
Registered
Joined
·
117 Posts
Discussion Starter · #4 ·
Yes i tried to prime the system before starting the car and doesnt makes a difference. And yes i mean cranking the engine 2-3 times n then it starts or i can do one but have to let the starter run for almost 4 seconds then if shut it off it'l start with no problem. Got to take into cosideration also that the car feels really weak in hot weather n sometimes it doesnt like 3 out of 10 times it happens to feel weak. Have stock air box and my MAFsensor has been cleaned. The car runs perfectly fine at night -__-
 

·
Registered
Joined
·
117 Posts
Discussion Starter · #5 ·
No cel codes.
Blue connector seems to be in the right place cuz it connects to the blue sensor and the other that is black connects to black one by the top of the airbox...
 

·
Electromagnetic Wave :-h
Joined
·
15,689 Posts
What are you running for fuel?
 

·
Electromagnetic Wave :-h
Joined
·
15,689 Posts
OEM gas cap?

When were the plugs last changed?

Check that you cannot blow air through the Purge VSV (clipped on the back of the airbox) w/the engine off.
 

·
Registered
Joined
·
117 Posts
Discussion Starter · #9 ·
Yes OEM gas cap
I replaced the plugs last year by october with bosch iridiums
The purge VSV u r talking about is the blue one or black one?
 

·
Electromagnetic Wave :-h
Joined
·
15,689 Posts
VSV for Evap

 

·
Registered
Joined
·
117 Posts
Discussion Starter · #11 ·
ok let me check that... Kind of think the problem is going to be that or somethnig related to the evap system. I just did some trips around lunch time when the temperature was around 95 and the car feels good sometimes and other times it bogs. When at a red light or a stop and when I take off again the car bogs or it just feels good regarless if a have the ac on or off.
 

·
Electromagnetic Wave :-h
Joined
·
15,689 Posts
Sounds like you are running rich & have difficulty starting at high temps. Does it also stall or hard start right after filling up w/fuel? If so, these are all signs that point to a stuck open or misconnected EVAP Purge VSV. Otherwise you are looking for things that may cause your power loss/bogging.... MAF, IAT, IACV, plugs, TPS, O2 sensors etc.
 

·
Registered
Joined
·
117 Posts
Discussion Starter · #13 ·
yes it does! car acts weird right after filling up the tank or also by putting a certain amount of gas. It takes longer to start and bogs a little after leaving the gas station then it kind of recovers... So it points out that I have to replace that EVAp Purge VSV? or maybe something else is causing this valve to mess up...
 

·
Electromagnetic Wave :-h
Joined
·
15,689 Posts
If it is the Purge VSV, it is either the valve is stuck open, you have vac lines misrouted, or you have the ASIC (butterfly valve) connector plugged into it by mistake (causes the Purge VSV to be open until 4k RPM).

Any of these will allow fuel vapors from the tank to feed directly into the TB. When you refuel, it pushes those vapors right up and will cause stalls. The same w/hot temps causing the vapor levels to rise in the tank and then sucked into the TB right away. However, if it is the EVAP Purge VSV, I'm surprised you haven't popped a CEL for the EVAP system yet. But, to me, your symptoms do point to the EVAP system.

Can you post a pic of the engine bay area around the TB & intake box?
 

·
Registered
Joined
·
117 Posts
Discussion Starter · #15 ·
Just did the check you told me of blowing air through the purge VSV with the engine off. Did it with the conection and hoses still on and with out anyting on off the engine bay and the air goes through it with out restriction so it is open all the time.
Here is the pic of bay let me know if you want a different one...

 

·
Electromagnetic Wave :-h
Joined
·
15,689 Posts
The Purge VSV (seen clearly in your pic on the back of the intake box) should only pass air when activated (electrically). If you disconnect it, pull it off, and can blow/suck air thru it, then it is bad. It looks, from the pic, like you have the correct connector going to yours.

Its possible, like mine, that there is something mechanically stuck in there preventing it from closing. Mine had a piece of charcoal or rubber stuck in it.

You can take it apart by squeezing the butterfly tabs holding the valve to the solenoid. Inside you will find a flap, a spring, a plunger, and the solenoid. The normal condition is that the spring pushes the flap up sealing off the two ports. When the solenoid is electrically activated, the plunger pulls the flap down towards the solenoid & opens the air passageway.

The last time I ordered one it was around $43. I can get you the part number if you need to replace it.

EDIT: 25860-22050 is the p/n & wholesales for around $63 now.
 

·
Registered
Joined
·
117 Posts
Discussion Starter · #17 ·
Ok going to take it apart and see if I can clean it or find out if its fixable still. Looks like we found the proble with this. Appreciate your help through all this problem so far. Let you know if I was able to fix the VSV
 

·
Electromagnetic Wave :-h
Joined
·
15,689 Posts
Good luck.
 
1 - 20 of 30 Posts
Top