NewCelica.org Forum banner
1 - 10 of 10 Posts

·
Registered
Joined
·
1,359 Posts
Discussion Starter · #1 ·
OK so i changed the engine about a month ago for used 2zz, everything was fine until tonight. I was exiting a parking lot & was switching from 2nd - 3rd gear when I heard a a noise that sounded like it hit a tire on the road or something. emediately after my power steering went out, my check battery light came on & I couldnt engage 2nd gear. I drove it fore about 2 blocks pulle dover & noted that the belts on the passenger side were trashed!

Help! has anyone had the same problem??? What is it & how much will it set me back to fix.

Again the belts are ripped, power steering went out, Im having hard time getting it in gear & the check battery light is on???? engine still running & sounds fine????
 

·
Ultraviolent
Joined
·
7,921 Posts
should be ok, saves you having to take off the old one:chuckles: get a new one and follow the steps thats in the INSTALLS section
 

·
Registered
Joined
·
7,714 Posts
well the power steering and battery light is because of the belt...since the PS and alt is ran by that.
 

·
Registered
Joined
·
795 Posts
Its the serpentine belt! Replace it yourself. A gatorback one costs about 35. Pretty cheap!
 

·
Registered
Joined
·
1,359 Posts
Discussion Starter · #6 ·
I took it to the shop & found out my ac compressor came loose. It has 3 screws & one of the brackets were broken o the block when i replaced the engine. i thought 2 would be good but obviously not! How can I fix this from happeing again??
 

·
Registered
Joined
·
1,359 Posts
Discussion Starter · #7 ·
Broken mount on engine for ac compresor. How can i fix it so the ac compressor dosent come loose again.
 

·
Registered
Joined
·
7,714 Posts
Well you need to fix the mount and put the correct amount of bolts in...torque them to spec.
 
1 - 10 of 10 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top