NewCelica.org Forum banner

1 - 14 of 14 Posts

·
Registered
Joined
·
2,064 Posts
Discussion Starter #1
the mr2 forums are always slow.. kinda want to get this fixed asap so hopefully someone here can help me.

i installed a mcculloch h4 kit this morning...

but when i try to turn on the headlights they do not turn on.. but when i switch to high beams they turn on.

if u are not familiar with h4 bulbs.. they do both high and low with one bulb.

anyone know how i can fix this to work normally?
 

·
Registered
Joined
·
448 Posts
Are your h.i.d's hi/low beam compatible ? if not then that may be the problem, if your h.i.d's aren't hi/low beam compatible then it wouldn't work on low beam. I think they would only go on when u got'em on high beam. But I maybe wrong here I'm just taking a guess. I think thats why some companys Like Xenon deopt sell the hi/low beam h.i.d's. I guess it's because some car/suv's have the one bulb that controls the high/low beams. But like i said I may be wrong.

Good luck and I hope you find out whats the problem :thumbup:
 

·
Registered
Joined
·
2,064 Posts
Discussion Starter #3
yea ur right... but i was hoping there is a fix for this.. like cutting wires and crap to make it work normally
 

·
Registered
Joined
·
448 Posts
Oh, I don't know anything about that....sorry. But if i was you i wouldn't cut any wires just to be on the safeside. Can't you just send the kit back and tell them it's not the one for your car. If not F**K it rock them like that :chuckle: and blind everybody that's in your way :chuckle:...nah j/k :D.
 

·
Registered
Joined
·
2,064 Posts
Discussion Starter #5
they dont light up as highs tho... when i hit the high beam the hids light up as lows.
 

·
Registered
Joined
·
27,517 Posts
How do you know it's lighting up as low beams when you hit the highbeam? What I mean is... if it's all coming from one bulb how can u tell the difference?

Sorry Eddie, I wish I knew how to help ya out on this one. Electrical engineering wasn't my major. :D
 

·
Registered
Joined
·
2,064 Posts
Discussion Starter #8
well i figured it out and it works normally now!
i had to switch some plugs around in the harness
 

·
Premium Member
Joined
·
18,200 Posts
Yeah, your problem was that power to the igniter was tied to the high beam wire instead of the low beam wire.
 

·
Registered
Joined
·
2,529 Posts
one thing you could have gone with was a D2S kit and use Caspers Electronics H4 --> D2S adapter/shield thing. I hear its pretty good since it offers a shield, plus you can just use D2S bulbs and ballasts from Philips, and not have to worry about your McCulloch ballasts ****ting out on you after a couple months!
 

·
Registered
Joined
·
2,064 Posts
Discussion Starter #11
?!? i thought mcculloch was a good brand. damnit atleast they have a 1 year warrenty
 

·
Registered
Joined
·
2,529 Posts
Originally posted by Dj_cElicA
?!? i thought mcculloch was a good brand. damnit atleast they have a 1 year warrenty
Well if you got it from an authorized US dealer, i think you should be fine. I (and some others) have had bad experiences with McCulloch hid kits..
 

·
Premium Member
Joined
·
18,200 Posts
pokgai said:
one thing you could have gone with was a D2S kit and use Caspers Electronics H4 --> D2S adapter/shield thing. I hear its pretty good since it offers a shield, plus you can just use D2S bulbs and ballasts from Philips, and not have to worry about your McCulloch ballasts ****ting out on you after a couple months!
I saw those things recently. Pretty damn slick. I was thinking about trying to get some Celica people together and trying to get some H7 ones made.
 
1 - 14 of 14 Posts
Top