NewCelica.org Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
501 Posts
Discussion Starter #1
I need help on replacing my high beam bulbs, I just bought new bulbs and tried to replace, but no success. I see the black thing which connects to the wires and the bulb and I tried pressing, holding, and pulling it but nothing happen I don't know if that's right or not or just scared something might happen, and if that's right how do I take of the black circle cover holding the bulb and if I do take it of is there any more to do, plus I live in Minnesota which right now the weather sucks and it's freezing outside, so I'm not sure if the black thing connected to the wires is frozen or not any link or guide would be AWESOME.
Thanks
 

·
Registered
Joined
·
1,224 Posts
That would be "twist" the bulb to remove it with the connector still attatched.
Then, you can clearly see the release on the connector to "pull" it off.
 

·
Registered
Joined
·
331 Posts
Replaced the halogen bulbs with a a pair of 9005 LEDs bidded in eBay and won for $3.25.

As the bros said, twist the base of the bulb counterclockwise. It should be loose from the socket and you can pull it out.

Installed the 9005 LEDs quickly and easily. They are very bright and work well. 9005 LEDs are available in a few colors, white, blue, yellow ect. I picked white to match the low beam so cops can't remmeber and target my car.

Had a hell of a time installing the H7 low beam LEDs because the OEM Halogen bulb uses an adapter at the base, so the clip ring press it in tight with enough stress to hold it tight. Withtou the adapter and with the weight of the fan at the base. LED bulbs wont seat properly in the socket.

Ij stead of modifying the adapter, I will just wrap a bunch of rubber bands at the base so the clip spring can work right. It may be a ghetto fix but nobody will see what it looks like in the engine bay.
 
1 - 5 of 5 Posts
Top