NewCelica.org Forum banner

1 - 14 of 14 Posts

·
Registered
Joined
·
306 Posts
Discussion Starter · #1 ·
Friendly run with a friend from a local msg board. He's pretty bleepin quick. We did a little 50mph-140mph run last night. Started at a bad point in 3rd gear for me, so it took like 3 months for my turbo to spool up. Here's the video. Video was taken from the LS1's passenger. We shut down right after I shifted into 5th, which is 140+. Incidentally there was a BPU+ twin turbo Supra, a Z28, and a Corvette running with us. They all ended up way behind us :p
 

·
Registered
Joined
·
600 Posts
CF, you're having WAYYYYY too much fun with that car! Better just give it to me now and save yourself any future health problems from OD'ing on adrenaline rushes! :D
 

·
Registered
Joined
·
306 Posts
Discussion Starter · #6 ·
Just some rods & pistons. The funny thing is my friend Shami is making almost as much power as I am, and she's on pump gas. I run race gas. And she has a completely stock engine with block guard. Bah!
 

·
Registered
Joined
·
355 Posts
For some reason, neither of your videos have worked for me :( I get the picture but it stays still while the audio plays. Even tried saving it first.
 

·
Registered
Joined
·
187 Posts
O2BQIK said:
For some reason, neither of your videos have worked for me :( I get the picture but it stays still while the audio plays. Even tried saving it first.
Same thing happened to me in Windows Media Player, needed updated codec...
 

·
Premium Member
Joined
·
2,255 Posts
Vroom_Vroom said:
this is just unreal with what you have done with your hatch man! good job and keep it up!
:stupid: mad props. :)
 

·
Registered
Joined
·
306 Posts
Discussion Starter · #11 ·
Yeah you need the right codecs. I'm not sure what encoding method is used, but WMP 9.0 should be able to play it. I have WMP 7.0 with a bunch of added on codecs and it works ok for me.

This last race was even closer than the race against that 122mph Trans Am. I started passing that TA while I was still in 3rd gear. With this LS1 Camaro it took me all the way to the top of 4th to get in front of him. :(
 

·
Registered
Joined
·
355 Posts
I put WMP 9 on there and it works now. Looks good Cheeze. I know turbo cars are inherently top-end oriented, but I'm really surprised you took that LS1 on the top end like that. Nice car man. Did that LS1 guy tell you his best trap speed?
 

·
Registered
Joined
·
9,255 Posts
BillWS6Formula said:
CF, you're having WAYYYYY too much fun with that car! Better just give it to me now and save yourself any future health problems from OD'ing on adrenaline rushes! :D
I'm next in line after you OD........ Puff, puff, pass by the ls-1!
 
1 - 14 of 14 Posts
Top