NewCelica.org Forum banner

1 - 14 of 14 Posts

·
Registered
Joined
·
378 Posts
Discussion Starter · #1 · (Edited)
I have a JL Audio 500/1 amp and a JL Audio 12 W6v2 sub. I also have reverse indiglo gauges, radar detector and some neons running off the cig lighter power source. Now everything is dimming and i mean EVERYTHING electrical. What should i get for a cap? or should i get a grounding kit, or what? Thanks

PS. I also want to add some cold cathodes or neons and maybe some single leds in the trunk after i get everything setup. What would/should i connect those to?
 

·
Registered
Joined
·
1,751 Posts
i would suggest also a battery strong enough to dish out all that strain you'll put on it..what kind of battery? i dunno maybe an optima. ground kit will help take the strain also and as far as a cap you can check on the actual cap and it should let you know the limits of it..
 

·
Registered
Joined
·
8,225 Posts
You need to get your alternator checked if you having that much trouble. I'm pushing over 1000wts of system and bunch of other stuff with underdrive pulleys and a 1 farad cap is just fine.
 

·
Registered
Joined
·
194 Posts
SickCelica696 said:
You need to get your alternator checked if you having that much trouble. I'm pushing over 1000wts of system and bunch of other stuff with underdrive pulleys and a 1 farad cap is just fine.

:stupid: i have two 500 watt amps, touch screen h/u, another screen, ps2, and neons and i've never once seen any dimming. and im not even using a cap or deep cycle battery or grounding kit. although i am picking up a deepcycle battery next pay day.
 

·
Registered
Joined
·
378 Posts
Discussion Starter · #5 ·
ok today, my system doesnt stay on consistantly, it will go on and off, so is that the alt? or should i get a cap
 

·
Registered
Joined
·
8,225 Posts
firestorm said:
ok today, my system doesnt stay on consistantly, it will go on and off, so is that the alt? or should i get a cap
Whats the HU? Most have a built in voltage protection circuit so that if you drop to 11~ they'll shut off to prevent totally killing the battery.
 

·
Registered
Joined
·
378 Posts
Discussion Starter · #8 ·
i have a Pioneer DEH-P700MP
 

·
Electromagnetic Wave :-h
Joined
·
15,531 Posts
You can drive it to me and I'll voltmeter it for ya... ;)
 

·
Registered
Joined
·
378 Posts
Discussion Starter · #10 ·
where ya live again? im busy almost this whole weekend from tommorow till monday. Lemme know when you could help me out 2way, i dunno which of the options i need to folllow
 

·
Registered
Joined
·
8,225 Posts
Does it go off if you sit around at idle? Then come back on when you start moving or tap the gas?
 

·
Registered
Joined
·
378 Posts
Discussion Starter · #12 ·
when im idling it usually isnt on, after 5 or 10 mins of running the car (while driving) it starts to kick in.
 

·
Electromagnetic Wave :-h
Joined
·
15,531 Posts
Sounds like low voltage/bad connection to head or alternator isn't doing its thing.
I'm in Plymouth... a bit of ride for you... I could always catch ya on my way home some night... too bad, too... cuz I took Fri. off...wouldn't have been a big deal if you showed up.
 

·
Registered
Joined
·
378 Posts
Discussion Starter · #14 ·
well, now i just moved some wires around in the back and it came in for a bit but then went away. I checked all the wiring and it is all tight and secure. Could it be that a wire from something else is affecting the system?
 
1 - 14 of 14 Posts
Top