NewCelica.org Forum banner
1 - 12 of 12 Posts

· Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
I have a 2002 Celica GT, recently it began idling rough had laggy throttle response and was misfiring. I scanned the CEL and got these codes; p0300 p0303 p0302 p0304 p0171 p0420. First thing I did was replace the o2 senors. This made the car run even worse. I checked my coils and spark plugs both were pretty bad so I replaced them, now the car doesn't run. It will start, idle rough and then stall out. If I turn the key all the way to the "off" position and try again it does the same thing, but if I leave the key in the "on" position and try to start it again it will not turn over. A mechanic tried spraying carb cleaner in through the intake manifold when we started it and that kept it running as long as we kept feeding it the carb cleaner. My first thought was a fuel problem so I checked the pump and it is good. Now Im running out of ideas and need help. Any ideas would be greatly appreciated.
 

· Electromagnetic Wave :-h
Joined
·
16,070 Posts
Did you reset the ECU after the O2 change?
 

· Registered
Joined
·
120 Posts
well rough idling could come from a bad idle air control valve or an EGR valve. thats where i would start next. however i had a few guys bring me a car running bad, alot of codes and rough idle, it was the ECU, BUT their car would not rev past 2 or 3k RPM or go faster than 30MPH gas pedal floored.
 

· Registered
Joined
·
4 Posts
Discussion Starter · #7 ·
Alright so I'm going to check out the fuel filter and injectors today.
I cleaned the MAF that was actually the very first thing i did.
Checked for vacuum leaks when it was still running and didn't find any.
I did not reset the ECU after I replaced the o2 sensors. I have a scanner so I'll resetting today.

Thanks for the suggestions.
 

· Premium Member
Joined
·
15,376 Posts
none of the 7th gen celicas have an EGR.

you need to find out why you are having misfires. and to correct your vocabulary. when you leave it in the on position, its turns over but does not fire.
 

· Registered
Joined
·
4 Posts
Discussion Starter · #11 ·
I assumed the misfires were cause by the engine running lean, not to mention my plugs and ignition coils were pretty bad.
Am I wrong in thinking that bad o2 sensors could cause the engine to run lean?
Also,since my car won't run, is there anyway I can test my catalytic converter without it running?
 

· Electromagnetic Wave :-h
Joined
·
16,070 Posts
I have a scanner so I'll resetting today.
Pull the EFI fuse or disconnect the ground side of the battery. A code scanner clearing will not reset the fuel map.
 
1 - 12 of 12 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top