NewCelica.org Forum banner
1 - 7 of 7 Posts

·
Muffinboy
Joined
·
1,606 Posts
JDM Cold Air Intake.......

2002 with fog lights... the only problem i had was part of my air dam was hanging down so i cut it off so it wouldnt drag... I have a video of it but for some reason it wont download off the camera... here are some pics of mine...



Throttlebody to CAI.




ByPass Filter.


I didnt put that second piece of plastic piping on that goes from my ECU


Looking through my Bumber in front of my driverside wheel.


Looking up at the main filter with the transmission in the background.


Not much room for the ByPass Filter...


The bushing/bolt for the mount along the finder where the stock intake was bolted in at.
 

·
Muffinboy
Joined
·
1,606 Posts
DesigningEcho said:
Any idea where I could find some of these covers? I might get one and just perforate it with some medium size holes just to be safe

Does your CAI have the bypass filter?

If it does dont worry about getting it wet.. it will be fine.
The CAI w/ bypass sucks through both filters. But more from the cold air then the ByPass. Its basically a short ram and a CA in one. The great thing is it sucks more out of the cold air then the bypass. Since the bypass is on there then there wont be a vaccum caused by the engine until it gets to the bypass filter.... So your engine wont be able to suck the water into the engine unless it is completely submerged. Quaint design if you ask me.

'The Muffin Man'
 

·
Muffinboy
Joined
·
1,606 Posts
????? There are no valves on the CAI. Just a two piece pipe, a donut filter and a cone filter with some cheap clamps (I'm a T-bolt kinda guy). Im sure if there was room for the filter you could put it on. But like the other guys said, as long as you stay out of the deep puddles then you will be fine. If you want the bypass then by all means but if you are just getting it to keep water out of your engine then you are wasting your money.


I myself am actually having some issues now. My check engine light is on because i have no place to plug my PCV in. Or atleast it looks like the PCV. It is the valve that opened the butterfly flap on the stock intake. Any ideas on how to get rid of it? Can I get a OBD-II flash on it?
 

·
Muffinboy
Joined
·
1,606 Posts
JOHN_B said:
Bypass valve.




Do you see that small little tube right but the Throttle body. It sticks out. It must be plug. That's probably causing the CEL.

First i apologize for the stupid questions, im running kinda slow tonight. Whats the picture of the bypass valve for?
Which small little tube? the metal one off of the intake manifold, or the black hose with the yellow dot on it?

And what about the valve i unplugged?
 

·
Muffinboy
Joined
·
1,606 Posts
JOHN_B said:

So connect that hose into the nipple off the intake manifold? So what about the other hose? It's a pressure line... what do i do with it? Where does it go to anyway? (I havent even looked at my engine that well)
 

·
Muffinboy
Joined
·
1,606 Posts
.........I'm an idiot....

Ok so what about the valve that I unplugged from the side of the butterfly valve? Leave it alone?
 
1 - 7 of 7 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top