NewCelica.org Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
Hello all,

I am hoping you may be able to help me out, but its not strictly Celica related.

I'm running an Elise 111R with the 2ZZ and for a few weeks now its been intermittently throwing up MIL P0328 errors. I replaced the sensor, but a few days later it was back on again.

I will be checking the wiring this weekend but I was hoping somebody on the forum may have had a similar problem before in their Celica and be able to point me in the right direction?

My concern is that the engine is in fact knocking excessively, perhaps due to an internal engine fault? I wouldn't know where to start with investigating this though?

FYI the car is MY 2003 and has done just over 10,000 miles. Any help you can provide would be greatfully received.

Kieran
 

·
Premium Member
Joined
·
9,606 Posts
I believe the "circuit high" code indicated that the sensor is malfunctioning... not the engine. I'd say replace the sensor first (should be pretty cheap and easy) then see if the CEL (or MIL as you called it) comes back.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #3
Thanks Silver Bullet - have replaced sensor already and it was fine for a few days but the error is now back.

The other thing I thought it may have been was that I overtorqued the nut when replacing the sensor, but then surely this would be a permanent rather than intermittent fault?

Thanks again for your help.
 

·
Electromagnetic Wave :-h
Joined
·
15,267 Posts
P0328 Output voltage of knock sensor is 4.5 V or more
(1 trip detection logic)
 

·
Electromagnetic Wave :-h
Joined
·
15,267 Posts
Thank the Matrix forum guys & Toyota.. lol..
That's an '03+ code & I had to grab that info out of a Matrix manual. Nothing around our forum to describe it... but, I'm sure it will come up more frequently as the '03+ crowd here start having more troubles.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #7
Thanks so much for that, really interesting information.

I'll get a multi-meter on it at the weekend and take it from there. Starting to feel a little less worried about the engine now!

Cheers.
 

·
Electromagnetic Wave :-h
Joined
·
15,267 Posts
Pinouts are from a Matrix... so, go by the Lotus info for KNK1 & EKNK.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #9
Just thought I'd let you know how I got on, tested circuit with a multi-meter over the weekend and all seemed fine. So I just re-crimped the connectors and all has been well since Saturday - hopefully that has sorted it!

Thanks again for your help with this.
 
1 - 9 of 9 Posts
Top