NewCelica.org Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
378 Posts
Discussion Starter · #1 ·
i was testing out the purge kit i got and after i connected the solenoid to the braided hose which went to the bottle, the connection at the bottle started to leak out some n20. I tried to cover it up using my fingers but obviously it was too cold. I tried to tighten the bottle afterwards and it kept leaking. It eventually stopped but what is wrong with it?
 

·
Registered
Joined
·
378 Posts
Discussion Starter · #2 ·
is there like a rubber peice i need around the bottles output thing?
 

·
Registered
Joined
·
378 Posts
Discussion Starter · #3 ·
wow, 40 views and not one person wants to comment on my problem? thanks guys....
 

·
Registered
Joined
·
949 Posts
umm.. maybe none of us 40 have nitrous, there are MAD turbo members around lately
 

·
Registered
Joined
·
1,268 Posts
you need to get some teflon tape and tape up the threads.......
 

·
Registered
Joined
·
378 Posts
Discussion Starter · #6 ·
i did but the **** just tears through it
 

·
Registered
Joined
·
80 Posts
If the teflon rolls up when you tighten the fitting, wrap the other direction. wrap it tight as possible and give it at least three layers. Good luck :burnout:
 

·
Registered
Joined
·
378 Posts
Discussion Starter · #9 ·
i know but its like the leak is coming from the VERY VERY small gap between the outlet and the outlets holding spot
 

·
Registered
Joined
·
80 Posts
Need to see the line and what its end looks like.... That style fiting on the tank ussually has a tapered seat...no need for teflon.. :shrugs:
 

·
Registered
Joined
·
378 Posts
Discussion Starter · #11 ·
i will post pics later tonight, right now im busy, thanks for the help jrs00gts and ahnjae check back tommorow, should have pics by then
 
1 - 11 of 11 Posts
Top