NewCelica.org Forum banner
Status
Not open for further replies.
1 - 16 of 16 Posts

·
Registered
Joined
·
153 Posts
Discussion Starter · #1 ·
I have a 2001 GT-S and as most of you know one of the things that sets the GT and GT-S apart is the high lift cams in the GT-S that kick in around 6500 rpm. Well lately my car hits lift only when it feels like it. Sometimes the rev limiter will kick in when i am at 7000 rpm in 1st gear. Sometimes instead of accelerating faster the car will actually just slow down when i am supposed to be hitting lift. It happens when the engine is warm/hot/cold... Sometimes i get lift, sometimes I dont. I called the dealer to set up an appointment for them to look at my car. The guy was givin me a hard time and sayin that nothing is wrong if the "check enine" light doesnt come on.

If you guys have had anything similar happen to your cars or know of something similar happening to someone else's car will you please help me out. I really want to get this fixed cuz its a waste of money to mod a defective car. Thanks in advance.
 

·
Registered
Joined
·
1,059 Posts
Are you new to the celica? Sounds more like your trying to hit lift right when you start the car. Which would be a no no.. Cause your temp is not ideal enough for lift to engage. If thats not the case, then I'm not sure. maybe a very dirty MAFS? In any event your dealer should find out what it is.
 

·
Registered
Joined
·
153 Posts
Discussion Starter · #3 ·
I try to hit lift after ive been driving for about 20-30 minutes and i still have the same problems. I know that the engine needs to be warmed up before u take the RPMs that high
 

·
Registered
Joined
·
1,788 Posts
Check oil level ...... this will disable the lift if it is to low, i guess for safety reasons, I have heard VERY few problems with this incident, althought the one guy did have a pin that was stuck in the engine that enablebled/disengaged the lift. Im almost possitive he did not have a check engine light on. Still take it to the dealer... all will be ok!
 

·
Registered
Joined
·
26 Posts
I had a problem with no CEL. It was a broken pin in an oil line in the head. Get them to check the oil pressure in the VVL system, that is how they diagnosed my problem.
 

·
Registered
Joined
·
2,480 Posts
Ag3ntOrangE said:
I have a 2001 GT-S and as most of you know one of the things that sets the GT and GT-S apart is the high lift cams in the GT-S that kick in around 6500 rpm. Well lately my car hits lift only when it feels like it. Sometimes the rev limiter will kick in when i am at 7000 rpm in 1st gear. Sometimes instead of accelerating faster the car will actually just slow down when i am supposed to be hitting lift. It happens when the engine is warm/hot/cold... Sometimes i get lift, sometimes I dont. I called the dealer to set up an appointment for them to look at my car. The guy was givin me a hard time and sayin that nothing is wrong if the "check enine" light doesnt come on.

If you guys have had anything similar happen to your cars or know of something similar happening to someone else's car will you please help me out. I really want to get this fixed cuz its a waste of money to mod a defective car. Thanks in advance.
The problem they are refering to is the stake bolt that secures the rocker shaft. The oil feed for the variable lift pins in teh rocker arms feeds though the shaft. The bolt has been known to snap which allows the rocker shaft to spin. This spinning causes the oil feed holes in teh rocker shaft to no longer line up with those in the head, which leads to intermittent and/or weak apply of lift and sometimes even early cancelation. It is most likely the very problem you are refering to.

Griffin
 

·
Registered
Joined
·
880 Posts
Godd luck man. I have a 2001 GT-S and have been fighting with three different dealerships to have my car fixed. It sounds like the same problem i am haveing. When it feels like it, it will it lift. I don't know what to do. Toyota dealerships seem like they don't even want to help me. Is there like a hotline number or something i can call to get this resolved??
 

·
Registered
Joined
·
2,480 Posts
Toyota has a hotline for their dealers to ask technical questions. If you make the dealer call them and explain that lift is not working intermittently then hopefully they will know about the broken stake bolt for the rocker shafts.

Griffin
 

·
Registered
Joined
·
4,198 Posts
Hmm...you are hitting the rev limiter at 7000 rpm and you aren't feeling lift...sounds like you have a GT. If you have a GT, you aren't going to feel lift.
 

·
Registered
Joined
·
3,110 Posts
2002GT_Celica said:
Hmm...you are hitting the rev limiter at 7000 rpm and you aren't feeling lift...sounds like you have a GT. If you have a GT, you aren't going to feel lift.

Dude, come on, I think he knows what kind of car he has. jeez.
 

·
Registered
Joined
·
33 Posts
I had this exact problem on my UK 190. It was caused by poor machining of one of the oil galleys in the cylinder head. A tiny fragment of metal had sheared off and was restricting the oil flow when it moved about. Thats why the fault was intermittent. It has been reported to Toyota Europe - don't know about the USA though! Car was in for 1 week and I have had it back for one week now and so far the lift works every time.
 

·
Registered
Joined
·
1 Posts
Are you new to the celica? Sounds more like your trying to hit lift right when you start the car. Which would be a no no.. Cause your temp is not ideal enough for lift to engage. If thats not the case, then I'm not sure. maybe a very dirty MAFS? In any event your dealer should find out what it is.
He's not knew my Celica is doing the exact see thing. I'm a mechanic and know it has nothing to do with it being cold and trying to Revit out the Rs somthing else going on. Gradually noticed it started to almost stutter when it would usually take off then that eventually turned to drowning out acceleration at 6500 rpms and up. Still goes up just sickly feeling and is the slowest rise in the entire range of accelerating rpms.
 

·
Electromagnetic Wave :-h
Joined
·
15,689 Posts
Still goes up just sickly feeling and is the slowest rise in the entire range of accelerating rpms.
Your description sounds like a MAF issue.

You're new here. Reviving a 19yr old thread is generally frowned upon. Consider starting a new one if you have a problem.
 
1 - 16 of 16 Posts
Status
Not open for further replies.
Top