NewCelica.org Forum banner
1 - 14 of 14 Posts

· Registered
Joined
·
134 Posts
Discussion Starter · #1 ·
Hello guys and thanks for looking.

I just recently replaced my clutch with an OEM japan clutch and resurfaced flywheel (professionally about 2 weeks ago). At first it was find my pedal was nice and hard (haha) it would go half way then last half would feel like a nice spring and pop back to half then soft rest half, which is perfect. Lately pedal has been slipping down and now it only releases almost near the end, and it is also a lot softer. I also replaced master cylinder at the same time as clutch because mechanic told me I was losing pressure because my flywheel was warped causing the slave to pump enormous amounts of fluids into master at high RPM. I wasn't able to release a gear until my RPM dropped. So that is the reason why I fixed those issues. Now it seems as tho my clutch isn't properly pressed down and I have a few times where I would try to downshift into 3 and it would grind. The clutch works PERFECT no slips nothing catches perfectly. But after I rev hard past 7 I feel like my clutch pedal gets really soft.

Here's my questions:
1. Is this normal if you rev hard on a stock? To break master cylinder quick?
2. If so, can I do something about it because its really annoying? As in aftermarket cylinders that can hold more pressure?
3. How can I fix this in general?

I know the clutch wears out fast at first and it slips down and gota tighten it again. But it shouldn't be getting soft and losing pressure.

THANK YOU guys. I'm completely depressed I spend 900$ hoping it would fix it and now its doing the same thing.
 

· Registered
Joined
·
109 Posts
Losing pressure on the pedal means you're either losing pressure elsewhere in the system or it simply can't build the pressure. As stated already, check the obvious places for leaks, any connection points, etc. I've seen some clutch cylinders leak IN to the car where the pedal goes through before as well, so check there. If you can't find any leaks, make sure the system is bled because any air in the system will cause all sorts of weird stuff depending on where it's trapped, the fluid temp, etc.
 

· Registered
Joined
·
134 Posts
Discussion Starter · #6 ·
Thanks guys I appreciate the help. As far as I know the slave isn't leaking because the mechanic told me this before changing my master. I'll try to bleed it and see what happens. It seems fine when its cold or when I drive slow, but when I try to crank up the rpms then it gets soft. Weird.
 

· Registered
Joined
·
134 Posts
Discussion Starter · #7 ·
New problem discovered: I was driving no more than 3500 on each gear down the street, had to stop due to a firetruck passing by, when starting back in first gear my clutch was loose...WTF please help guys.
 

· Registered
Joined
·
134 Posts
Discussion Starter · #9 ·
loose as in my pedal gets loose when i press it and its not disengaging/engaging properly, wont let me put it in a gear unless i pump it a bit.

i appreciate it a lot man, but it doesn't ever do it when i try to show it to people.. its just random and annoying. any ideas?
 

· Premium Member
Joined
·
15,376 Posts
i re-read your first post and that mechanic is full of crap. the slave putting too much pressure on your master causing the flywheel to warp. yeah im gonna call big :bs: on that one. if you replaced the master and the slave then it must be the clutch install or something like that. i really cant tell without seeing the car. next time you need work done on the car, bring it to me
 

· Registered
Joined
·
134 Posts
Discussion Starter · #11 ·
ok. now i noticed that on a cold start it works great but then tends to loosen after going and stopping at lights and or in traffic. im not burning the clutch because if i was itd be gone by now. maybe its heat related? i really dont have the budget to go and replace parts to find whats wrong. thank you.
 

· Registered
Joined
·
134 Posts
Discussion Starter · #13 ·
no i have not replaced the slave cylinder.. how would i know its that? because i dont want to spend money for no reason -.-.. No i have bled it yet but it was just installed you still think there might be air in there? thanks
 

· Registered
Joined
·
5,241 Posts
Bleed it.
 
1 - 14 of 14 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top