NewCelica.org Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
28 Posts
Discussion Starter · #1 ·
At 2K and only 2K does this problem seem to manifest in my 2000 GT w/ 150K. I've traced every goddamn exhaust hanger/heat shield and this is definitely buzzing/whistling from the midpipe. It sounds like an obstruction or if you put something in the blades of a fan when it was going. I can deal with the sound, but the "man, who's POS car is that?" looks get old when cruising through the parking lot and my girl can't stand it. I try and goose it and shift at 1500-1750 and its not too noticeable. In 10 years and maybe 90K miles, I've replaced the cat 3x, the muffler 2x, and now the midpipe. Last year I posted a thread bitching about how my muffler hanger bracket rusted off; I took an Autozone hanger and just bent it in place on the subframe, and with a new muffler the car was fine and running great, no noise and no issues. Then in winter time, my cat split after the downstream o2 sensor and I had a shop weld a connector in place for cheap.

I'm hoping to get a cheap welder and maybe do straight pipe or something in the place of the resonator. I'm sick of taking it to shops for something stupid like the exhaust. The car has been good to me... besides a qt of oil maybe every/3K miles, I'm still getting 30+ mpg and it hasn't let me down once. But the exhaust issues... is there anybody here who has had to go through this many replacements on a stock Celica? It's not like I'm using cheap ebay shit for my replacement parts, but I'm thinking it's the oil burning + New England salt up here in winter.
 
1 - 3 of 3 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top