NewCelica.org Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
874 Posts
Discussion Starter · #1 ·
Well i replaced the clutch on my sisters car last weekend...and this is the 4th/5th time ive ever replaced a clutch on a celica....anyhow it grabs real good but for some reason its slipping in lift, in 2nd and up........when lift kicks in at a little over 6000 rpms I can hear the lift kick in but the car isnt pulling, the clutch slips.................i though it could be grease on the flywheel or something but then again it grabs when not in lift..... Anyone encountered this problem? could it be the lift bolts?

Someone please help cuz this is giving me nightmares everynight!!!!
 

·
Registered
Joined
·
1,436 Posts
when the clutch slips, does the rpm shoot up? or are you just experiencing a lack of power?

if you gotten grease on the clutch/flywheel during the install, that can cause it.

what happens if you put the car in 5th/6th gear and floor it? does it bog or does the rpm go up?
 

·
Registered
Joined
·
874 Posts
Discussion Starter · #3 ·
everything is normal other than hitting lift....I can hear the engine hitting lift but i dont feel anything
 

·
Registered
Joined
·
1,436 Posts
is it a lost of power or does it feel the same as first cam?
 

·
Registered
Joined
·
874 Posts
Discussion Starter · #5 ·
no loss of power....just slipping when hitting lift.....i think i overfilled the transmission fluid since it was on an incline.....so i leveled the car and drained it, quite a bit came out....car feels a lot faster but yet lift still slipping..... I predict that when i overfilled it, fluid may of overflowed due to pressure and onto the clutch plate and flywheel????? is this possible scenario???? can someone confirm that this is a possibility?
 
1 - 5 of 5 Posts
Top