NewCelica.org Forum banner

1 - 20 of 20 Posts

·
Registered
Joined
·
2,312 Posts
Discussion Starter · #1 ·
Got a CEL on the way into work this morning, took it by Autozone on my lunch to get the code pulled.

Turns out to be 3 codes.

P0440 Evaporative Emission Control System Malfunction
P0441 Evaporative Emission Control System Incorrect Purge Flow
P0446 Evaporative Emission Control System Vent Control Circuit Malfunction

Could this be due to the gas cap? It is a 2000 GT A/T. The only thing aftermarket is an SRI, but I checked all hoses and it seems fine. I am planning on replacing it with the stock airbox within the next few weeks or so.

I also make sure that the gas cap is all the way closed every time I fill up.

What could it be?
 

·
Electromagnetic Wave :-h
Joined
·
15,527 Posts
Blue Bomber said:
440: Evaporative Emission Control - System Malfuction

- Hose or tube cracked, hole, damaged or loose seal
- Fuel tank cap incorrectly installed
- Fuel tank cap cracked or damaged
- Vacuum hose cracked, hole, blocked, damaged or disconnected
- Fuel tank cracked, hole or damaged
- Charcoal canister cracked, hole or damaged
- Open or short in vabpor pressure sensor circuit
- Vapor Pressure sensor
- Fuel tank over fill check valve cracked or damaged
- ECM


441: Evaporative Emission Control - System Incorrect Purge Flow
446: Evaporative Emission Control - System Vent Control Malfunction


For both codes:

- Vacuum hose cracked, hole, block damaged or disconnected
- Open or short in vapor pressure sensor circuit
- Vapor pressure sensor
- Open or short in VSV for EVAP
- VSV for EVAP
- Open or short in VSV for vapor pressure sensor
- VSV for vapor pressure sensor
- Charcoal canister cracked, hole or damaged
- Fuel tank over fill check valve cracked or damaged
- ECM
Sure sounds like gas cap...mess w/any hoses or electrical connectors near the SRI?
 

·
Registered
Joined
·
2,312 Posts
Discussion Starter · #5 ·
2way said:
Sure sounds like gas cap...mess w/any hoses or electrical connectors near the SRI?

Nope, not in a while at least. I did top up the gas tank after it finished the last time I bought gas, could that have something to do with it? Just remembered that.
 

·
Registered
Joined
·
5,355 Posts
techgeekwill said:
2way said:
Sure sounds like gas cap...mess w/any hoses or electrical connectors near the SRI?
I did top up the gas tank after it finished the last time I bought gas, could that have something to do with it? Just remembered that.
Yeah, it could.
 

·
Registered
Joined
·
623 Posts
I'm in the same boat. My car just gave me the same three codes...again. It did it the last time I got gas, then I used my reader and reset the codes. All was fine until this weekend when I filled up again. I got the codes on Tues, reset, and this morning they came back. Tues eve. I checked my gas cap for tightnes and also flipped the o-ring around. Then I made sure it was on good and tight. My GTS has 112,xxx miles, and I have a e-bay/bb mod cai. The only thing I've done recently was clean my air filter and maf. I may look into checking/replacing the hoses since some vacuum hose should be relatively cheap. How much is a gas cap from the stealership?
 

·
Registered
Joined
·
2,312 Posts
Discussion Starter · #9 ·
SharkyGTS said:
I'm in the same boat. My car just gave me the same three codes...again. It did it the last time I got gas, then I used my reader and reset the codes. All was fine until this weekend when I filled up again. I got the codes on Tues, reset, and this morning they came back. Tues eve. I checked my gas cap for tightnes and also flipped the o-ring around. Then I made sure it was on good and tight. My GTS has 112,xxx miles, and I have a e-bay/bb mod cai. The only thing I've done recently was clean my air filter and maf. I may look into checking/replacing the hoses since some vacuum hose should be relatively cheap. How much is a gas cap from the stealership?

dont buy a gas cap at a stealer!!

go to autozone or something. It'll be $8 or something like that.
 

·
Registered
Joined
·
623 Posts
Well, I just reset the codes and removed and checked the vsv and purge control valve. I wrote down the part numbers from them. The vsv = 9091012221. The purge valve = 9091012220. Partznet has the vsv (looked up by p/n) at like 36.00, and the purge valve (also by p/n) at like 48.00. While browsing through the emission section of the mechanical catalog on partznet, the vsv listed there is like 50.00, but it has no p/n. I wonder what the difference is.?. One of the hoses on my purge valve was loose, so I tightened the clamp a bit with some pliers...we'll see if the damn CEL comes back on. If so, I may buy the damn valves. Stoopid smog control crap!!! Enough ranting. Hope some of this is usefull to ya'll
 

·
Registered
Joined
·
185 Posts
Noob question: :newbie:
I got the same code, but is it something I should fix asap -is it bad for the engine-?, or is it just something regarding smog check -my next one is in 01/08 (1 yr 1/2)?
 

·
Electromagnetic Wave :-h
Joined
·
15,527 Posts
SharkyGTS said:
If so, I may buy the damn valves.
Check the charcoal canister & hoses.
 

·
Registered
Joined
·
623 Posts
Looking at my service manual cd rom, it appears to be under the car behind/on top of the gas tank. I'm going to crawl under the car tomorrow and have a look. It appears as though there is a vsv on the canister itself in addition to th ones in the engine bay. I'll see about yanking it out and getting the part number while I'm under there.
 

·
Registered
Joined
·
2,312 Posts
Discussion Starter · #17 ·
SharkyGTS said:
Looking at my service manual cd rom, it appears to be under the car behind/on top of the gas tank. I'm going to crawl under the car tomorrow and have a look. It appears as though there is a vsv on the canister itself in addition to th ones in the engine bay. I'll see about yanking it out and getting the part number while I'm under there.
fvck, that is a pita to get to. Glad I dont have to fix it until january.
 

·
Registered
Joined
·
623 Posts
Yeah, I think it is going to a suck. I'll know more after saturday. Technically, I don't have to have it fixed until Jan of '08, but the damn cel bugs the sh*t out of me. Besides, I like to tinker. OT, you're in Conroe? I grew up in Rosenberg...down 59 past Sugarland. One of my friends in school at Tx A&M at Galveston exploded his ankle wake boarding on lake conroe. His foot was stuck in the binding while the board rotated almost 360. It was pretty gnarly.
 

·
Registered
Joined
·
2,312 Posts
Discussion Starter · #19 ·
SharkyGTS said:
Yeah, I think it is going to a suck. I'll know more after saturday. Technically, I don't have to have it fixed until Jan of '08, but the damn cel bugs the sh*t out of me. Besides, I like to tinker. OT, you're in Conroe? I grew up in Rosenberg...down 59 past Sugarland. One of my friends in school at Tx A&M at Galveston exploded his ankle wake boarding on lake conroe. His foot was stuck in the binding while the board rotated almost 360. It was pretty gnarly.
Damn, small world. I don't trust Lake Conroe one bit. Too many stumps and crap in the bottom, plus its full of stupid ******** any time we go out there.

The problem is finding time for this crap. I wont be able to get to it this weekend, maybe the next since I have to change my oil.
 

·
Registered
Joined
·
623 Posts
Well, I got under the car, and figured out where everything was at. The carbon canister is right above the muffler. to get to it you have to drop the muffler, then remove the heat shield on top of the muffler, and the canister is there. I didn't feel like yanking the muffler, so I let it be. Plus, my channel lock pliers are at work. They make short work of popping the muffler hangers apart. As far as the lake and the rednekkks, what do you expect? It's east TX, the bible belt, etc. Can't you hear the banjos? I am a native Texan, but I could do without the uber ******* east TX folks. The whole rest of the state is pretty normal. Maybe it's got something to do with the Piney Woods..I dunno.
 
1 - 20 of 20 Posts
Top