NewCelica.org Forum banner
1 - 20 of 22 Posts

·
Registered
Joined
·
1,092 Posts
Discussion Starter · #1 ·
Just click on the folder new turbo and you will see my new set-up. This was all the pics. I could take as they had the rest of the car closed up with the dust pans. http://photos.yahoo.com/goforit2816
 

·
Registered
Joined
·
1,092 Posts
Discussion Starter · #4 ·
larryd said:
You just need to lose the ECU cooler tube :)
I want to get rid of that funky orange/red hose but Billy my tech says it's there for a reason. When I get the car back I'll take it off:gap:
 

·
Registered
Joined
·
7,726 Posts
Jay where did you mount the FTC1-E? Inside cabin or in the engine bay? I mounted mine in engine bay but now I wish I mounted it inside, this way its not much of a problem hooking a laptop to the unit.
 

·
Registered
Joined
·
1,092 Posts
Discussion Starter · #6 ·
cool2miketlu said:
Jay where did you mount the FTC1-E? Inside cabin or in the engine bay? I mounted mine in engine bay but now I wish I mounted it inside, this way its not much of a problem hooking a laptop to the unit.
Hey Mike we just mounted the unit today and I had to call Mark, he sent us the FTC1 not the E model so we can't control obd2! He said we can still use it or send it back, he also mentioned that he did the same thing to you. We had no room in the engine bay to mount it so we mounted it on the drivers side under the dash. there's alot of room in there and enough wire so we didn't have to add any. I was told the car will be on the dyno Weds. I'll beleive it when I see it!
 

·
Registered
Joined
·
7,726 Posts
hahaha Yeah Mark did the same thing with me :) I had to go back and have them rewire everything on :D I would actually move it over to the passenger side next to center console, so that when computer is plugged in the wire will not get in the way :)
Well we can always keep our fingers crossed on dyno :) I am hopeful that it will be done soon :D
 

·
Registered
Joined
·
22,454 Posts
Jersey Jay said:
I want to get rid of that funky orange/red hose but Billy my tech says it's there for a reason. When I get the car back I'll take it off:gap:
Bah, its an ECU cooler tube so your ECU doesnt overheat. It just sends air from the fans to the ECU housing. I ran without mine for several months with no problem. And as much as you drive that car Im sure youd have no problems.
 

·
Registered
Joined
·
7,726 Posts
I don't know Dave, turboed engine is alot hotter. All the hot-air gets trapped in there may cause the ECU to overheat. Better to leave it there, just in case.
 

·
Registered
Joined
·
22,454 Posts
Turbod engine should not be that much hotter in the engine bay itself. Ofcourse the manifold is alot hotter but that air should cycle right out under the car.
 

·
Registered
Joined
·
1,092 Posts
Discussion Starter · #11 ·
Hey Larry I saw Charlie at the shop today with his new turbo, it's big. Sorry to hear that your car is not running hopefully it's only something minor.
 

·
Registered
Joined
·
1,092 Posts
Discussion Starter · #15 ·
cool2miketlu said:
Its Wednesday night... I guess no dyno time eh :(
Nope no dyno the only thing that gone today was I polished my Volks. I called Mark @ 8:30 PST and told him to send me a replacement for the wrong FTC next day priority am ups. 16 leads and a vaccum hose then were on the dyno to tune, keep your fingers crossed. The 238 sae hp was with the safc, I guess having the battery disc. for a week helped. Did your read Keyshawns thread on his tranny? It's giving me 2nd. thoughts on running it at full boost with my tranny:wtf:
 

·
Registered
Joined
·
7,726 Posts
naaa I don't think you have to worry too much about that, you ardly drive yours and his is daily driven. The good thing about this FTC1-E adapt to laptop is you can just load settings to the unit, maybe dyno for high boost and low boost, low boost for daily driving and high boost to produce high HP. Just make sure you adjust the boost controller before changing the piggyback unit numbers :D
 

·
Registered
Joined
·
1,092 Posts
Discussion Starter · #19 ·
cool2miketlu said:
naaa I don't think you have to worry too much about that, you ardly drive yours and his is daily driven. The good thing about this FTC1-E adapt to laptop is you can just load settings to the unit, maybe dyno for high boost and low boost, low boost for daily driving and high boost to produce high HP. Just make sure you adjust the boost controller before changing the piggyback unit numbers :D
Well I got the right ftc1e @ 7:30 EST today. It's all wired in and ready to go but we have a problem. We tried 2 different laptops to program the piggy back but they both froze up and sid it could not communicate with the ecu? I spent 1/2 an hour on the phone with Mark @ split second and we still can't figure it out. My shop does alot of Motec and Halteck systems so this should have been a cake walk for us. I have no clue and I'm at a loss for words, anyone have a clue?
 

·
Registered
Joined
·
7,726 Posts
is this addressed to me? I am the only other person I know on this board that has this...
hmmmmm wonder if all wires are connected right, check all wires first...
2nd check the connection cable to the computer does it have a bent pin?
After all that I would check the notebook operating system, maybe conflict in the configuration?
Mark said when ever you enter something and want it to write to the FTC1-E you have to turn off engine and leave key at on position, did you do that?
These are the only things I can think of, sorry can not be of any more help. I have not hooked up a laptop to the ECU yet so not sure how this works.

If all of above is not the problem then the only other possible problem I see is the unit was damaged during shipping maybe?
 
1 - 20 of 22 Posts
Top