NewCelica.org Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Bought a non starting Celica 2000 T230 1.8VVTi. It cranks but does not start. I noticed that the check engine lamp is not turned on when i switch on the ignition and i cant get any connection with an OBD adapter.
All fuses in engine room and passenger side fuse box are ok. Have measured with a multimeter at the fuel pump but no power on the 12v connectionr. Signal wires are working fine as i can see the fuel level.
Tried moving around the horn relay that i know is working to the other relay slots like, EFI, IG, C/OPN but no luck.

Tried disconnecting all sensor wires i could find in the engine room to see if it could be a shorted sensor but it didnt help either.
Have opened up the ECU (ecu 89666-20050) and made a visual inspection of the PCB and it all looks ok. No swollen capacitors and no burned traces.
What can i try next?
 

·
Registered
Joined
·
2 Posts
Bought a non starting Celica 2000 T230 1.8VVTi. It cranks but does not start. I noticed that the check engine lamp is not turned on when i switch on the ignition and i cant get any connection with an OBD adapter.
All fuses in engine room and passenger side fuse box are ok. Have measured with a multimeter at the fuel pump but no power on the 12v connectionr. Signal wires are working fine as i can see the fuel level.
Tried moving around the horn relay that i know is working to the other relay slots like, EFI, IG, C/OPN but no luck.

Tried disconnecting all sensor wires i could find in the engine room to see if it could be a shorted sensor but it didnt help either.
Have opened up the ECU (ecu 89666-20050) and made a visual inspection of the PCB and it all looks ok. No swollen capacitors and no burned traces.
What can i try next?
thanks for the info.http://myaccountaccess.live/
 

·
Electromagnetic Wave :-h
Joined
·
15,635 Posts
If there is no power @ the fuel pump, check the voltages @ the C/OPN relay.
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #4 · (Edited)
If there is no power @ the fuel pump, check the voltages @ the C/OPN relay.
Thanks for the reply. Finally got some time to test and there is no power to EFI1/EFI2 and no power to c/opn (relay is tested and working)

I then connected power to the c/opn signal and battery+ directly from the battery. Now my check engine light turns on and i can get contact with the OBD scanner (no fault codes)
But there is still no 12v to the fuel pump only 5v signal power.
 

·
Electromagnetic Wave :-h
Joined
·
15,635 Posts
Solve the no power to EFI 1 & 2. Check the 20A EFI fuse & the EFI Relay.
 
1 - 5 of 5 Posts
Top