NewCelica.org Forum banner
1 - 1 of 1 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Hey guys, so i'm new to this forum and this is my first post. I have a 2001 celica gt, i've had it for over a year now. I started getting a check engine light about 4 months ago and didn't bother to have it checked because the engine ran fine and everything else checked out ok. I decided to have Toyota check it out for me. They told me that there was a problem with the variable timing and that it was the OCV. I thought, OK this shouldn't be a big deal to fix. Wrong! I had to wait for Toyota to ship the part in so I went to Oreillys and bought the part. I swapped it out, fine. I went to start the car and POP! the motor wouldn't even turn over. I checked the OCV and found it to be HOT. I reset the computer and started the engine. The resistance on the new OCV was off so I new it had blown. I tell Toyota this and they say oh well we still have to replace the ocv. They replaced the ocv and said it was good to go, I take it for a drive and the cel came back on. I take it back to toyota again. They say the ocv went bad again. So now there have been 3 ocv's that have gone bad. They can't pinpoint what is causing it. I'm assuming that if it was a electrical issue or ecu problem that their tests would tell them. I don't know what to do right now. The car still runs fine.
 
1 - 1 of 1 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top