NewCelica.org Forum banner
1 - 11 of 11 Posts

·
Registered
Joined
·
31 Posts
Discussion Starter · #1 ·
Hello all. I've been out of touch w/the Celica community for quite awhile. Since then, I've been having issues with my Celi. (A coincidence I'm sure!) Each morning when I start up, it will turn over but idle VERY rough. After a few seconds of idling that gets worse by getting slower, it eventually dies. After it does this, I can start it up just fine. But when I go to pull out of the parking lot, I have to very gradually press the accelerator or else it will kill it. After it's been running for 15-20 minutes, this problem seems to go away. It does the same thing when I leave to go to lunch after it's been sitting there for 4-5 hours. After the 15-20 minute "warm up period" of driving is over, I can hit the accelerator about half way down to speed up and it will be fine, but if I floor it all the way, it sounds like a person who's been punched in the stomach: gasping for air, revving real loud, then it will shift into gear after a couple of seconds. Can anybody please offer any advice? I know if i take it to the dealer they won't look at it b/c of the CAI. TIA!
 

·
Registered
Joined
·
1,152 Posts
Take out the MAF sensor and see if it has gunk on it, if so clean it out with carb cleaner or MAF cleaner.

It may not be the problem but worth a try...
 

·
Registered
Joined
·
634 Posts
hmmm... toyota dealers are @#$hole, wherever they are right? even here in Jakarta.

well.. 2 months ago i have similiar problem (not exactly the same). my car would hesitate and RPM would drop and died, while stopping in the traffic light or intersection, and while idling, the RPM have very very rough idling and sometime i could here backfire. it was so bad , that it died in the garage during start up. so i decided to bring the car to another racing car workshop, where i started to see the light that most Toyota dealers don't wanna go for all the trouble to check our car.

anyway here is what they find, and the car has been running perfect until now:
1. Dirty Fuel filter
don't trust the manual which say that our celica has lifetime fuel filter. that's bulls^&it!! mine was only 45,000 km, and the filter was so dirty that it needs replacement. it cost me around $40 here, should be cheaper in the USA
2. Blown MAFs
the Blown MAFs has caused my car to die, since it couldn't read the Air Flow coming through, and this what had caused the bogging and hesitation. well.... you could check and cleaned it first, if it doesn't work, replace it. i have replaced mine 2 times in a year!!!!! first one was blown during a flood, and the latest one was blown for unknown reason.
3. DIrty IACV
clean the IACV, and make sure it is clean, and also clean your throttle body.
IACV and MAFs are closely related, so make sure both are clean and work properly...
4. Spark Plugs...
Have u checked your plugs? make sure they are good and not dirty, mine was also replaced (after using Greddy Iridium for 1 year only!!!) with Denso IK20.
5. Fuel injector and Seals.
When the car is gasping for air... it looks like it's running lean, just like mine.
the garage took a close look, and found out the seals are leaking, and can see the fuel are sipping through the seals. they replaced the seals (4 of them). the seals are dirt cheap, but it is a pain in the @#$ to get them out and change them.

The car is running perfect now, and i think you might very well have the same problem like me. don;t do it by yourself, bring it to a repair workshop... preferably not Toyota.

let me know once you solve your problem
 

·
Registered
Joined
·
31 Posts
Discussion Starter · #4 ·
Thanks for the knowledge detasemen88. A friend of mine's son used to work for Toyota but has his own shop now. I called him today and explained the situation to him and he's going to check it out Monday morning.
 

·
Registered
Joined
·
634 Posts
GreyStreet said:
Thanks for the knowledge detasemen88. A friend of mine's son used to work for Toyota but has his own shop now. I called him today and explained the situation to him and he's going to check it out Monday morning.
no worries dude... ;)
 

·
Registered
Joined
·
163 Posts
hey grey the problem sucks hate to hear about it, but my camry had a problem with that, it was th throttlebody cause we drove through some deep water. hope this helps and good luck.
 

·
Registered
Joined
·
31 Posts
Discussion Starter · #7 ·
spidermanjay3 said:
hey grey the problem sucks hate to hear about it, but my camry had a problem with that, it was th throttlebody cause we drove through some deep water. hope this helps and good luck.
so how did you fix it?
 

·
Registered
Joined
·
163 Posts
luckily the warranty was in effect, and i lied about the flood part cause thats an insurance thing, warranty doesn't cover flooding, i'll take a look at the receipt but i think they justreplaced it,
 

·
Registered
Joined
·
4 Posts
Question- can anyone solve this?? driving down the high-way with the throttle in a stationary position the car by itself slows down (loses some power) then comes back full on this happens contiunously during the trip- any and all suggestions are welcome- please
 

·
Registered
Joined
·
72 Posts
This is on an Automatic right? Are you throwing any codes? It could be the spark plugs. My honda Accord did that durring the harsh winter temp. I had to warm it up for 5-10 minutes then sometimes when I step on it it bogs then I let off the gas then go again and it will be fine. So change spark plugs and check it out.
 
1 - 11 of 11 Posts
Top