NewCelica.org Forum banner
1 - 11 of 11 Posts

·
Registered
Joined
·
824 Posts
Discussion Starter · #1 ·
so havnt driven my car in a few days so i took it out for a spin drove to a friends house 1/4 mile away from my house i decide to hit lift and make sure i can still land the 1 to second shift, well i shift stay in lift so i let go off the gas and the rpms still going up i throw in nuetral and its bouncing off the rev limit i shut of the ignition pulled over in a road with no lights or any thing put my hood started checking my throttle lines all good when i look at tb it was wot i play with it it closes and i hear a clank clank clank go down my short ram i take off my short ram and i find the bottom half of the maf sensor broken off so and it was in the intake it was wat jammed the tb from closing so im guessing im gonna need a new maf sensor? so any suggestion to wich sensors are better since im gonnna be installing my turbo in a month or 2???
 

·
Electromagnetic Wave :-h
Joined
·
15,879 Posts
Have you been cleaning it w/some kind of brake cleaner or some other cleaner? There are some contact cleaners on the market that will eat/deteriorate plastics.

You, definitely, need a new MAF now. OEM/Denso. What you do w/turbo later, may have different requirements.
 

·
Registered
Joined
·
4,236 Posts
thats insane! haha that air must have been really movin!

correct me if im wrong, but i know the STi MAF is supposedly better, but without a tune it doesn't work, or at least doesn't work well. So in the mean time you might have to get a stock one...
 

·
Daddy Daycare
Joined
·
20,305 Posts
If you're the first owner of the car and you have no intake then I'd say a manufacturing flaw on the MAF. If not then it's quite possible previous owner messed the MAF up.
 
1 - 11 of 11 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top