NewCelica.org Forum banner
21 - 27 of 27 Posts

·
Electromagnetic Wave :-h
Joined
·
15,636 Posts
Timing chain off by a tooth?
 

·
Registered
Joined
·
1 Posts
alright guys im stumped, ive been working on this issue for a while, searching threads and trying anything i find.

i have a 2000 celica gt auto (stock). the problem is my car will run fine for a while and then i get random bog downs, to the point that i have to pull over and shut the car off. it boggs down when i hit the gas, no acceleration, barely can get it to 20 mph to get it down the street. when i park it at my house and later try to figure out what it is i start it up and it runs fine again... wtf its like chasing a ghost. previously i was getting a p0171, but after i replaced the upstream o2 sensor it went away and has yet to return. the problem still happens at random times.

i tryed cleaning the spark plugs, cleaning the injectors, disconnected and reconnected all the vacuum hoses to verify no leaks, new o2 sensor, cleaned the maf, cleaned the air filter.and still get the problems every now and then.

frustrating as hell lol.

thanks guys for any advice or help.
This
Did you check compression on all cylinders?

If compressions are low or uneven between cylinders, it could be worn piston rings or valve seal leaks Engine woudl run rough and weak, sometimes cannot start.

Do a dry compression test then a wet one with oil in cylinders to find out if compression loss is due to worn piston rings or valve seals leak.

Compression can be improved drastically by flushing oil with Motor Medic Engine flush ($5 Walmart). It will dissolve and clean out hardened oil varnish on rings and valves, restoring compression. It can make engine run strong and smooth.

Engine oil should be cleaned and flushed with this treament every 5,6 oil changes. My enegine was running very rough, lots of vibration due to uneven compression after 50,000 miles of adding but not changing oil. Engine flush dumped out about half quart of thick black mud. Engine ran smooth and strong like new after.
alright guys im stumped, ive been working on this issue for a while, searching threads and trying anything i find.

i have a 2000 celica gt auto (stock). the problem is my car will run fine for a while and then i get random bog downs, to the point that i have to pull over and shut the car off. it boggs down when i hit the gas, no acceleration, barely can get it to 20 mph to get it down the street. when i park it at my house and later try to figure out what it is i start it up and it runs fine again... wtf its like chasing a ghost. previously i was getting a p0171, but after i replaced the upstream o2 sensor it went away and has yet to return. the problem still happens at random times.

i tryed cleaning the spark plugs, cleaning the injectors, disconnected and reconnected all the vacuum hoses to verify no leaks, new o2 sensor, cleaned the maf, cleaned the air filter.and still get the problems every now and then.

frustrating as hell lol.

thanks guys for any advice or help.
this is late but the problem is feul pump
 

·
Registered
Joined
·
14 Posts
alright guys im stumped, ive been working on this issue for a while, searching threads and trying anything i find.

i have a 2000 celica gt auto (stock). the problem is my car will run fine for a while and then i get random bog downs, to the point that i have to pull over and shut the car off. it boggs down when i hit the gas, no acceleration, barely can get it to 20 mph to get it down the street. when i park it at my house and later try to figure out what it is i start it up and it runs fine again... wtf its like chasing a ghost. previously i was getting a p0171, but after i replaced the upstream o2 sensor it went away and has yet to return. the problem still happens at random times.

i tryed cleaning the spark plugs, cleaning the injectors, disconnected and reconnected all the vacuum hoses to verify no leaks, new o2 sensor, cleaned the maf, cleaned the air filter.and still get the problems every now and then.

frustrating as hell lol.

thanks guys for any advice or help.
Having the same problems!
 

·
Electromagnetic Wave :-h
Joined
·
15,636 Posts
Or fuel filter. If it's always bogging, then MAF.
 

·
Registered
Joined
·
14 Posts
I've chaned the fuel filter already. New spark plugs. New air filter, new valve cover gasket, intake gasket, pcv valve, and changed one injector, oil change with amsoil, changed both oxygen sensors, replaced maf too. Bought the maf from ebay from another celica owner. Possibly the maf I got was not good as well? I'll have to check with a electrical tester. Will buy a brand New one if need be.
 

·
Electromagnetic Wave :-h
Joined
·
15,636 Posts
CRC MAF cleaner.
Do you have an OBD scanner? If so, post up the fuel trims.
 
21 - 27 of 27 Posts
Top