NewCelica.org Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
50 Posts
Discussion Starter #1
My Trial exhaust has recently been making really loud rattling noises when the car is started up. I was thinking about getting a replacement but Trial is making me pay shipping to and from Japan so Im gonna try some other tests to see what the problem is. I checked all the nuts and bolts including the hook mounts and everything is tight so I'm sure it's not caused by any of that. I asked my brother about and he said that it is because of back presurre on the cat. It's strange because after I drive for a little while it stops. Has anyone had any experiences with this?
 

·
Registered
Joined
·
656 Posts
I have the same problem with my GT. Does yours rattle at just at idle or say around like 2800 - 3000 RPMS when you are engine braking? Part of my rattle was the heat shield, I tightened that up and it helped but I think it has to do with something on the internals of the exaust (sounds like its coming from the cat). oh ya I have a TRD exaust though.
 

·
Registered
Joined
·
624 Posts
check if your gasket is still there..mine had a rattle and i looked and it was missing
 

·
Registered
Joined
·
2,590 Posts
also could be bad cat, my friend just figured out it was his cat.
 

·
Registered
Joined
·
50 Posts
Discussion Starter #6
soceur said:
also could be bad cat, my friend just figured out it was his cat.
Yeah, I think it is coming from the cat. How did your friend fix the problem? Did he have to buy a brand new mid-pipe? and would it be covered under the warranty? Thanks.
 

·
Registered
Joined
·
656 Posts
I would say just buy a high flow cat and have an exaust shop put it on, that'd probably be the cheapest way.
 

·
Registered
Joined
·
2,590 Posts
it was fixed under warranty. He got a whole new exhaust system in 30min:)
 
1 - 8 of 8 Posts
Top