NewCelica.org Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
44 Posts
Discussion Starter #1
I've been having a small exhaust leak under load/acceleration back from pretty much as far as I remember since I got my 2001 GT in 2006, even after I replaced the front flange gasket and spring bolts back in the day it didn't completely go away. A few years back, the original engine killed the cat with its oil consumption and ultimately committed suicide as well. I had 05 GT engine installed, didn't do it myself as I should have done which I regret but that's another story. I replaced my whole midpipe/cat last year and used new flange gaskets and spring loaded bolts all around but I can still hear the same original hiss from the exhaust on acceleration, especially when I have my windows rolled down. Since it only happens when the engine is under load it's hard to pinpoint (don't hear it at all when revving in neutral) but I'm pretty certain it's coming from the front section of the car. Having all new gaskets and new midpipe/cat and after the engine has been replaced my only pointers would be either a small crack in the exhaust header, header warp/damage of some sort, or the exhaust manifold gasket that I'm certain wasn't replaced with the engine. It's not a major issue as there are/were no CELs and it runs fine, it's just an annoyance.. Anyone with ideas how to locate the leak or a possible fix if it sounds familiar?
 

·
Daddy Daycare
Joined
·
20,303 Posts
You'll have to get the heatshields off and check the header/gasket area for black deposits. If there's a tiny leak you're supposed to see a little bit of suit.
 

·
Registered
Joined
·
4,466 Posts
Or take it to a shop and pay them to diagnose. Realize they'll stop after finding their first possible source of leak, though.
 
1 - 3 of 3 Posts
Top