NewCelica.org Forum banner

1 - 20 of 42 Posts

·
Banned
Joined
·
4,595 Posts
Discussion Starter #1
Now this has got me baffled.

Before I learned to launch my times were 14.8-14.9 with 2.4 60's and 10.0-10.1 1/8's....

Now i get 2.2 60's and my 1/8's are 9.4-9.6 but i cant get any better than a 15.0

would a going clutch be the cause??? Im baffled :(

Same conditions (car wise) for all the runs...just my intake.
 

·
Registered
Joined
·
12,350 Posts
hmmm. I always thought when you got your 2.2's you'd be 14.6's easy.
 

·
Banned
Joined
·
4,595 Posts
Discussion Starter #3
i think my clutch is starting to go :( but i dont understand how i could launch that well with a slipping clutch...
 

·
Registered
Joined
·
12,350 Posts
Originally posted by EasyC
i think my clutch is starting to go :( but i dont understand how i could launch that well with a slipping clutch...
Well slipping a launch helps a high RPM launch. It may be benefiting your launch.
 

·
Registered
Joined
·
210 Posts
same here when i was stock doing 2.4 60 foots i managed a 15.19 at best. But with an injen cold air intake and 55000 miles on the car i only managed a 15.05 at best with a 2.29 60 foot. I was like wtf I know I should be able to get at least a 14.9. I do notice that I can't land at 6400-6500rpms like I use to be able to although I still can land it at least at 6100 rpm (1st to 2nd shift btw). All I could come up with was its the clutch, but then I thought if it were the clutch then how the hell can I even get close to 2.29 60 foots. I mean to my knowledge I don't think? my clutch slips. Thats the only thing keeping me from buying an aftermarket clutch is that if it doesn't benefit me then why get it at all unless I get forced induction<<not gonna happen
 

·
Registered
Joined
·
1,647 Posts
are you running stock wheels EasyC?
 

·
Vendor
Joined
·
15,564 Posts
hey easy can you post complete info form those slips - it will give us a better idea whats happening.
 

·
It is known.
Joined
·
8,235 Posts
Originally posted by NoRulzAt140 Mph
Well slipping a launch helps a high RPM launch. It may be benefiting your launch.
sounds like what mine is doing
 

·
Registered
Joined
·
1,151 Posts
LaoBoyJames said:
I do notice that I can't land at 6400-6500rpms like I use to be able to although I still can land it at least at 6100 rpm (1st to 2nd shift btw).
How the hell did you land 6400-6500rpms from 1st to 2nd? Your full of crock. Unless you were powershifting or soemthing, you cant land at 6500.
 

·
Registered
Joined
·
12,350 Posts
Originally posted by Tuppuguy
How the hell did you land 6400-6500rpms from 1st to 2nd? Your full of crock. Unless you were powershifting or soemthing, you cant land at 6500.
with the right amount of wheel spin you can, but the wheels spin negates the landing point.
 

·
Registered
Joined
·
272 Posts
Tuppuguy said:
How the hell did you land 6400-6500rpms from 1st to 2nd? Your full of crock. Unless you were powershifting or soemthing, you cant land at 6500.
i've landed 6700 before.

so?

some people can. it depends on the amount of wheelspin you get on the shift.
 

·
Registered
Joined
·
12,350 Posts
Originally posted by 00TRDGT-S
i've landed 6700 before.

so?

some people can. it depends on the amount of wheelspin you get on the shift.
yes. Wheel spin. BUT there is NO benefit to wheel spin. Landing 6100-6200 is better than 6500.
 

·
Registered
Joined
·
1,151 Posts
NoRulzAt140 Mph said:
yes. Wheel spin. BUT there is NO benefit to wheel spin. Landing 6100-6200 is better than 6500.
I cant even land 6100. The best was 6000 for me. I usually land around 5800-5900. My friend who's been driving manual all his life drove my car and had the same problem. no matter where he shifted (ei 7800, 8000, 8200) he would land around 5900. Is something wrong with my car?
 

·
Registered
Joined
·
12,350 Posts
Originally posted by Tuppuguy
I cant even land 6100. The best was 6000 for me. I usually land around 5800-5900. My friend who's been driving manual all his life drove my car and had the same problem. no matter where he shifted (ei 7800, 8000, 8200) he would land around 5900. Is something wrong with my car?
No. also there is no reason to shift lower than 8350. Thats the MAIN reason. Also, there is nothing wrong with your car. Its all practice.
 

·
Registered
Joined
·
1,647 Posts
crap
 

·
Registered
Joined
·
1,151 Posts
NoRulzAt140 Mph said:
No. also there is no reason to shift lower than 8350. Thats the MAIN reason. Also, there is nothing wrong with your car. Its all practice.
I dont think you can drive normally and hit lift from 1st to 2nd. I think you have to keep the gas partially depressed when shifting in to 2nd. Just tried it during my lunch break, i landed around 6100 with the tires chirping alittle. Or maybe i dont want to admit that i shift like an old lady. I also grinded the fook out of my 2nd gear trying to shift too fast. Norulz, next time at englishtown let me know what i'm doing wrong.
 
1 - 20 of 42 Posts
Top