NewCelica.org Forum banner
1 - 8 of 8 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter · #1 ·
alright guys......... i am getting my car ready to sell and i have to fix a few things........ dont tell me i need to take it to the dealership b/c they are all assholes and try to screw me over..... first i need to fix my taillights. no fuses are blown and the brake and reverse lights still work, but i have no taillights...... as for the only other major thing, i have absolutely no clue what it is... CEL is on, car has trouble starting and bogs down through all rpm's.... dealer said my cat was gone, as in not on, i caught him in a lie, and pulled my car out....... i think it could be an o2 sensor but that is just a "s.w.a.g.". oh, and when i try to crank my car, it acts like the battery is almost dead thern it fores right up...... its a new battery......... can somebody please help me..... thanks
 

·
Registered
Joined
·
2,894 Posts
First thing I would check for the brake lights is your fuses for them. The next thing I would do would be to go to AutoZone and get your CEL read and see what it is telling you is the prob. They will do this for free for you. Then you can figure out how to proceed from there.
 

·
Registered
Joined
·
7 Posts
Discussion Starter · #4 ·
haven't thought of a vacum hose....... as for the lights, i have checked my fuses and they are all good..... do you think it could be a relay ????

oh, btw.... what is a MAF ???? thanks...........
 

·
Registered
Joined
·
256 Posts
MAF= Mass Air Flow Sensor, its a little square sensor with wires coming out of it thats screwed on the intake pipe connected to the throttle body.
 

·
Registered
Joined
·
7 Posts
Discussion Starter · #6 ·
thanks....... how can i tell if its bad
 
1 - 8 of 8 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top