NewCelica.org Forum banner
1 - 7 of 7 Posts

·
Premium Member
Joined
·
4,756 Posts
Discussion Starter · #1 ·
Everytime Im shifting into second gear I hear a squeak! What could it be??? Does it just need WD40 in the shifter???
 

·
Zettai Unmei Mokushiroku
Joined
·
28,865 Posts
WD-40 = bad for rubber boots, bushings, and hoses. It will eventually eat away at them. Use white lithium grease instead.

Pop open the hood. If you have a CAI or short ram intake, this will be easy. Look behind the intake, and you'll see some gold linkages. Spray all of their joints, and you squeaking should go away. If you don't have an intake, try to spray around the stock airbox to hit the linkages. You can also remove the driver side undercarriage plastic to get to them.
 

·
Registered
Joined
·
881 Posts
Blue Bomber said:
WD-40 = bad for rubber boots, bushings, and hoses. It will eventually eat away at them. Use white lithium grease instead.

Pop open the hood. If you have a CAI or short ram intake, this will be easy. Look behind the intake, and you'll see some gold linkages. Spray all of their joints, and you squeaking should go away. If you don't have an intake, try to spray around the stock airbox to hit the linkages. You can also remove the driver side undercarriage plastic to get to them.
Do you know the exact name of the grease? Would home depot have it.
 

·
Registered
Joined
·
1,295 Posts
Its actually called "White Lithium Grease" at least thats what it says on my can. I found this thread today I wanted to fix that squeak I've heard a lot of 6spds with that problem.
 

·
Registered
Joined
·
791 Posts
get the spray. It's available at an autoparts store. Don't go crazy lubing everything. You will attract more dirt and crap which will make things worse. Spray what you need to.
 
1 - 7 of 7 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top