NewCelica.org Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
47 Posts
Discussion Starter · #1 ·
With the car stopped and I press the gas, occasionally nothing happens. Then after a few seconds things return to normal and I can accelerate . The car has 120k miles so could it be bad MAF, injectors, sparks , battery, fuel filter etc. I had the car serviced at 75k and new battery at 60k?
 

·
Registered
Joined
·
4,279 Posts
Time for a tuneup maybe? I think it's your IACS.

For starters change your sparkplugs, clean MAF, IACS, put in a bottle of seafoam, new fuel filter, PCV valve, oil, tranny, etc.
 

·
Zettai Unmei Mokushiroku
Joined
·
28,865 Posts
That's bogging. Check/clean your MAFS and O2 sensors first. If you've got an aftermarket intake, that may also be the cause.
 

·
Registered
Joined
·
11,169 Posts
^^^ Concur with Bomber.

Also, is it worse after a cold start? The whole point of the recommended 10 sec warm up is to allow the primary O2 sensor to heat up. If it doesn't light off fast enough due to carbon build up, this could also throw things off.
 

·
Registered
Joined
·
634 Posts
i have been discussing this too... since i also had the some problems, right Jordan?

unfortunately for me (spent the whole week) i have done the following:
1. Replace Battery / fix ALternator (Last year)
2. Blown MAFs - got it replaced for USD 150.00 2 weeks ago
3. Damn dirty IACV - got the throttle body removed and cleaned throughly...
4. Replaced the fuel filter for about USD 100.00
5. replaced the Iridium Spark Plugs with DEnso IK20
6. Clean O2 Sensor- it was dirty
7. replaced the injector seals - 4 of them!!!

The car is perfect now..... before, i had pretty similiar problem with you, worse maybe. my car would not crank... or would stall and died at intersection or when coming to a stop.... Good luck man
 

·
Registered
Joined
·
521 Posts
My car did that. I press the gas, and the RPMs would just stick around 1000 or so, even with 3/4ths throttle down. It was my MAF, I cleaned it and it helped quite a bit but wasnt 100% good, so I replaced the MAF altogether. I actually have my old MAF thats been cleaned, I dont know that you would want it, but I'd sell to you cheap if you'd like to try it. It has 63k miles on it.
 
1 - 6 of 6 Posts
Top