NewCelica.org Forum banner

1 - 13 of 13 Posts

·
Registered
Joined
·
164 Posts
Discussion Starter #1
Hey guys, just looking for some input for this problem... I did use the Search function but I didn't really come up with anything that really fit the bill. Sorry if I missed something that was right in front of me though.

Anyways, this is the thing. I got this car early October of 2011, and the tach wasn't working then. When I say not working, I mean nothing happens when the car starts. The needle just sits at 0. It's really not that big of a deal to me, because I've learned to drive without it, but I'd really like to get it working again.

The guy we got the car from said that the tach was working fine until they got a new clutch installed. He was going to have it checked out and fixed before we bought the car, but no dice there.

I'm just guessing that when the clutch was replaced they might have accidentally snapped a wire or something? I'm not really that car smart, but I'm learning. I've definitely learned a lot since I joined this site, but that's not kind off topic from what I'm asking.

Sorry that I ramble, bad habit. Any help or thoughts would be greatly appreciated!
 

·
Registered
Joined
·
276 Posts
Then the speedometer would not work!
More info on the car...
I ASSume it is a 7th gen Crapica
 

·
Banned
Joined
·
186 Posts
i dont think he talking about the rpm tach but the speed tach, because if it happened when they installed the clutch, then it would most likely be the speedo, i think the op got confused and actually means the speedo and not the tach, but i could be wrong, op please tell us more about your car and if you actually mean the tachometer or the speedometer.
 

·
Registered
Joined
·
164 Posts
Discussion Starter #7
Sorry, more info -- Yep, it's a 7th Gen GT-S, year 2000.

I always just assumed the tach was for the RPM's, but I guess it could have caused some confusion? :confused:

The speedometer works fine, it's just the tachometer.
 

·
Registered
Joined
·
276 Posts
Do you have a MIL/Check Engine Light?
A tach has always been RPM to me also...
TIS
 

·
Banned
Joined
·
186 Posts
lol my bad than i always was told that the tach could stand for the speedo and for the acutal tachometer, but now i know thanks smaay and dsmer
 

·
Registered
Joined
·
164 Posts
Discussion Starter #10
No CEL's, and everything else looks to be operating fine. I'll check those three suspect areas for the tach not working. Where did you find that?
 

·
Registered
Joined
·
276 Posts
That is TIS, It is for Toyota Technicians

Check your fuse first if you have no CEL
 

·
Premium Member
Joined
·
12,227 Posts
find someone with a GTS and use their gauge cluster, its possible that the cluster itself has failed
 

·
Registered
Joined
·
164 Posts
Discussion Starter #13
Okay, I'll check the fuse first. It is possible if the fuse was bad for the gauges it would only affect the tach?

I don't think I'll find somebody's GT-S gauge cluster to use. :p Here in Middle-of-Nowhere, Iowa, I've never seen another 7th gen Celica. I've only seen one other celica, actually -- a 6th Gen down in Omaha.
 
1 - 13 of 13 Posts
Top