NewCelica.org Forum banner
1 - 10 of 10 Posts

·
Registered
Joined
·
1,644 Posts
Discussion Starter · #1 ·
I guess all of you thought it was closed tonight, but it wasn't......It should have been though...I couldn't get traction off the line for anything.....I was pulling 2.3 60fts with the azenis! i was only launching from 3000 and still spinning:bang: Anyway, I know some of you are interested in my traps, so ill post them. I was running 14.4 all night....
my traps
97.80
97.40
97.82
97.92
98.15
98.32
98.22
98.30
98.15

As you can see, my traps went up a little bit, but it just may have been because I couldn't get traction. Hopefully next week will be better.
 

·
Registered
Joined
·
1,039 Posts
When the last time you change your oil? This can hurt your performance alot. When I running my old car to the track and I alway run the same time, but then later I went back I ran worst. Someone told my maybe it your oil that need to be change. Well I did it, then I ran better than my best time. Try doing that, it should help out. Also be careful running your car too many time at the track, you can do damage to your tranny. Your car isn't made to run at the track all the time. Unless you have race tranny setup than I say go keep racing.
 

·
Registered
Joined
·
1,644 Posts
Discussion Starter · #6 ·
Well, I am do for an oil change......I guess every little bit helps.
Also, one of the reasons i left was because I didn't want to keep beating on my car for such ****ty times....Now if i was running 14.00 than I would have stayed to try and hit 13's, but it just wasn't worth it last night.
 

·
Registered
Joined
·
5,377 Posts
I didn't go because it was still raining down here. I drove up last time for nothing. If it ain't sunnier than hell I'm not going.
 

·
Registered
Joined
·
5,207 Posts
they need to finish seminole raceway it hasn't rained here in almost a week...and at night it gets into the mid low 60s
 
1 - 10 of 10 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top