NewCelica.org Forum banner

1 - 14 of 14 Posts

·
Registered
Joined
·
59 Posts
Discussion Starter #1
I was checking out the 1/4 mile database, and I was looking at everybodys trap speed. For some reason mine(88.83 mph) is higher than all the others who are running 15.67 and slower, with the exception of a 6 speed gts(91.30 mph). Does anybody know why that is. I was running on stock tires and if you check out this http://www.newcelica.org/other/tracktimes/view.php?id=325 you can see what mods i had at the time. Does anybody happen to know why my trap is higher than the others, even when people are running better 1/4 mile times? Thank you!!
 

·
Registered
Joined
·
59 Posts
Discussion Starter #3
2.359, hoping to make that better next time, seeing that I have ES Motor Mount Inserts now....and I was dropping it from 4500 RPM :( but later I read your "how to launch" thread, so I will slip it next time.
 

·
Registered
Joined
·
1,647 Posts
his 60' is on his sig, i dont know.. seems like somethings wrong at your track
 

·
Registered
Joined
·
59 Posts
Discussion Starter #6
Well, on my 2nd best run of that night, I ran a 15.949 @ 88.91 mph, with a 60' of 2.440....this run woulda been alot better than my current best one if my 60' was in the 2.3's....
 

·
Registered
Joined
·
772 Posts
Originally posted by wirolla
Well, on my 2nd best run of that night, I ran a 15.949 @ 88.91 mph, with a 60' of 2.440....this run woulda been alot better than my current best one if my 60' was in the 2.3's....
If you spin the tires off the line, you end up with higher trap speeds and lower e.t.'s as far as I've seen....

now if you were to come up with a 2.3 or 2.4 from bogging the car, you'd have a slower trap.

I have mine decent about 4500 to 4800 for a 2.1x 60', slipping the clutch..... no tirespin whatsoever, my traps went down but the e.t.'s are quicker.

I am still trying to get the "illusive" launch down... but whenever I attempt to drop the cluch from high rpm and ease up on the throttle I get wheel hop.... I get wheel hop even if I let all the way off the gas!
 

·
Registered
Joined
·
12,350 Posts
Originally posted by Liqquid
If you spin the tires off the line, you end up with higher trap speeds and lower e.t.'s as far as I've seen....

now if you were to come up with a 2.3 or 2.4 from bogging the car, you'd have a slower trap.

I have mine decent about 4500 to 4800 for a 2.1x 60', slipping the clutch..... no tirespin whatsoever, my traps went down but the e.t.'s are quicker.

I am still trying to get the "illusive" launch down... but whenever I attempt to drop the cluch from high rpm and ease up on the throttle I get wheel hop.... I get wheel hop even if I let all the way off the gas!

:werd: Basically.
 

·
It is known.
Joined
·
8,235 Posts
Originally posted by wirolla
2.359, hoping to make that better next time, seeing that I have ES Motor Mount Inserts now....and I was dropping it from 4500 RPM :( but later I read your "how to launch" thread, so I will slip it next time.
1. your launching too high.....bring down to about 3500
2. what is your front tire psi at? bring it down to about 20psi
3. if you like your clutch don't slip it......you'll end up needing a new on sooner than you'd like
 

·
Registered
Joined
·
349 Posts
with my GT celica i launched at 5500rpm. the technique worked for me, but i doubt it was good for my stock clutch
 

·
It is known.
Joined
·
8,235 Posts
Originally posted by NOrwayGT
with my GT celica i launched at 5500rpm. the technique worked for me, but i doubt it was good for my stock clutch
no........no it wasn't :gap:
 

·
Registered
Joined
·
272 Posts
deflate to 15-18psi. 20+ up is still a bit high

the rpm you launch at depends on how your car puts the power down.
but when the light turns green, start hold the throttle and let the clutch out 1/2 way so it starts grabbing (basically slipping), then when you have moved forward a few feet without any wheel hop or excess tire spin (some spin is normal), floor it and dump the clutch.
 
1 - 14 of 14 Posts
Top