NewCelica.org Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
23 Posts
Discussion Starter · #1 ·
Hey guys, I have the TWM shortshifter, i installed it about a month ago, and its been great, but now it's starting to act a little funny, first of all , when the stick is in neutral it sort of tilts to the right, i have a 5 speed Gt and its so hard to get it into reverse, it takes about 3 tries, then when im driving every gear is very hard to slide into place, and it slips a lot. What can the problem be, i checked everythign and it seems to be tight and in place, i dunno. somebody help.
 

·
Registered
Joined
·
1,505 Posts
1. it's supposed to tilt to the right
2. just use some force getting it into reverse
3. lube the shifter linkages

i've had mine for over a yr now and it's been great
 

·
Registered
Joined
·
579 Posts
exactly what was said above... plus for reverse, make sure your on the brake when your shifting... i notice that if i let off the brake a tad too soon trying to hit reverse, it doesn't want to go... if make sure im in reverse before i let off the brake, it works much better...
 

·
Registered
Joined
·
23 Posts
Discussion Starter · #4 ·
It's supposed to tilt to the right? i didnt know that, but thats cool, i just want to make sure that i did everythign right and didnt mess anything up, thanks for the advice though , i lubed up everything, maybe i could try lubing it all again, what do u use, i just used grease, is there better stuff?
 
1 - 6 of 6 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top